Bug 130038 - Alignment of text in Shapes is broken
Summary: Alignment of text in Shapes is broken
Status: RESOLVED DUPLICATE of bug 130482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2020-01-16 17:24 UTC by Cor Nouws
Modified: 2020-02-12 09:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2020-01-16 17:24:54 UTC
- New text document
- Insert > Shape > Basic shape > Rectangle
- Draw shape
- type 'foo'
- Ctrl+E (should center)
  > Nothing happens
- Ctrl+R (should align right)
  > Nothing happens

Noticed in Version: 6.5.0.0.alpha0+
Build ID: ce685f64f38551e7984155783c9c7660d986abf6
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-01-11_00:53:31
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Cor Nouws 2020-01-16 17:25:28 UTC
works fine in e.g. 6.0.7 => regression
Comment 2 Cor Nouws 2020-01-16 17:28:39 UTC
by the way: the icons on the tool bar don't help either :)
Comment 3 Dieter 2020-01-16 19:45:17 UTC
I confirm it with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 350d25da375f221edfa37309324ce3c68cf297ef
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Works fine in LO 6.3.4.2
Comment 4 Telesto 2020-01-18 20:26:28 UTC
CTRL+E is working fine before this commit & starts crashing afterwards
author	Szymon Kłos <szymon.klos@collabora.com>	2019-11-08 17:13:05 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2019-11-11 14:25:13 +0100
commit	a3c7a8282ddd08c7ed4a15d23089d09e418f8fae (patch)
tree	00f5b11225acc1abe88bb7deeda873172d54cca9
parent	572a8132e0e460b17c80c456dfb5e07f6b9a9c6a (diff)
jsdialogs: apply .uno:Color and CharBackColor to floating text frames

Crashing is resolved with, but CTRL+E isn't working
author	Szymon Kłos <szymon.klos@collabora.com>	2019-11-14 11:16:04 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2019-11-14 21:36:05 +0100
commit	77cc0e929ee331af6b97b65e9b6ec5400ef05cd4 (patch)
tree	f941d0f616e548042e06fc3814abe47e64072ca3
parent	2c354558454e66c158c71164eaf56ad18433291c (diff)
jsdialogs: fix CID 1455691 & CID 1455690


Adding CC to: Szymon Kłos
Comment 5 Jean 2020-02-12 07:26:33 UTC
Version 6.4.0.3 :
- click on UI icons -> crash
- Ctrl+E -> crash
Comment 6 Maxim Monastirsky 2020-02-12 09:01:57 UTC

*** This bug has been marked as a duplicate of bug 130482 ***