Download it now!
Bug 130052 - Calc 6.4.0: Selection of Text with hidden rows copies all text
Summary: Calc 6.4.0: Selection of Text with hidden rows copies all text
Status: RESOLVED DUPLICATE of bug 36466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-17 12:37 UTC by Axel Braun
Modified: 2020-01-17 14:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Braun 2020-01-17 12:37:37 UTC
Description:
I have a table with some rows hidden.
When I select an area of the table, CRTL-C and paste is (Content only - Text) into another table, it copies as well the hidden rows

Version: 6.4.0.1
Build-ID: 40(Build:1)
CPU-Threads: 4; BS: Linux 5.4; UI-Render: Standard; VCL: kf5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

Steps to Reproduce:
1. table with hidden rows
2. copy part and paste into different table
3.

Actual Results:
all content - including hidden rows - is copied

Expected Results:
only visible = not-hidden content is copied


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Xisco Faulí 2020-01-17 13:51:40 UTC
Hello Alex,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Timur 2020-01-17 14:29:02 UTC
Looks like a duplicate.

*** This bug has been marked as a duplicate of bug 36466 ***