Bug 130085 - Double menu bar in the print preview
Summary: Double menu bar in the print preview
Status: RESOLVED DUPLICATE of bug 128491
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Preview
  Show dependency treegraph
 
Reported: 2020-01-20 08:11 UTC by Vbxler
Modified: 2020-02-18 08:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Double menu bar in the print preview (17.34 KB, image/png)
2020-01-20 08:11 UTC, Vbxler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vbxler 2020-01-20 08:11:08 UTC
Created attachment 157259 [details]
Double menu bar in the print preview

Every time the printer preview is opened there is an additional menu bar in the print preview and also in the work area.


Version: 6.4.0.2
Build-ID: 08d19fecdc7a2298d051e19cfdb7c35544855fc3
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 1 Dieter 2020-01-20 10:47:12 UTC
Can't confirm with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 350d25da375f221edfa37309324ce3c68cf297ef
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 2 Ryan Carter 2020-01-20 15:35:11 UTC Comment hidden (spam)
Comment 3 Timur 2020-01-20 16:48:34 UTC
We had a spammer confirming bug, so I set back Unconfirmed.
Vbxler, did you search for open and closed bugs if this is a duplicate?
Please do. Write if you use Global menu as in bug 126870.
Comment 4 Xisco Faulí 2020-01-21 12:38:55 UTC
Hello,
Do you get a double menu if you follow the steps from bug 128491 ?
Comment 5 Xisco Faulí 2020-01-21 12:40:15 UTC
OTOH, do you reproduce it if you launch LibreOffice from commandline with:
SAL_USE_VCLPLUGIN=gen soffice ?
Comment 6 Amr Ibrahim 2020-02-01 10:42:00 UTC
(In reply to Vbxler from comment #0)
> Every time the printer preview is opened there is an additional menu bar in
> the print preview and also in the work area.

Reproducible with the LanguageTool extension added to LO:
Version: 6.3.4.2
Build-ID: 1:6.3.4-0ubuntu0.18.04.1~lo2
CPU-Threads: 8; BS: Linux 5.3; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

Not reproducible without LanguageTool.
Comment 7 Amr Ibrahim 2020-02-01 10:50:13 UTC
(In reply to Xisco Faulí from comment #5)
> OTOH, do you reproduce it if you launch LibreOffice from commandline with:
> SAL_USE_VCLPLUGIN=gen soffice ?

I can't reproduce the bug with "SAL_USE_VCLPLUGIN=gen soffice".

Here is the terminal output:
$ SAL_USE_VCLPLUGIN=gen soffice
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
Comment 8 Timur 2020-02-02 11:42:39 UTC Comment hidden (obsolete)
Comment 9 Amr Ibrahim 2020-02-02 14:14:34 UTC
(In reply to Timur from comment #8)
> Reporter didn't respond, we don't know whether he and Amr use Global menu
> and if this is a duplicate of bug 126870.

I don't use a global menu. I'm using GNOME Shell, which does not have a global menu.
Comment 10 Dieter 2020-02-18 08:20:32 UTC
(In reply to Amr Ibrahim from comment #6)
> Not reproducible without LanguageTool.

So do you think, we can treat this as a duplicate of bug 128491?
Comment 11 Amr Ibrahim 2020-02-18 08:26:45 UTC
(In reply to Dieter from comment #10)
> So do you think, we can treat this as a duplicate of bug 128491?

Yes.
Comment 12 Dieter 2020-02-18 08:36:26 UTC

*** This bug has been marked as a duplicate of bug 128491 ***