Bug 130089 - CRASH: Writer throws an exception on Quit
Summary: CRASH: Writer throws an exception on Quit
Status: RESOLVED DUPLICATE of bug 125352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2020-01-20 15:09 UTC by Gerry
Modified: 2020-01-20 16:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SwPageFrame::RemoveFlyFromPage(SwFlyFrame *)"]


Attachments
Sample file (261.36 KB, application/vnd.oasis.opendocument.text)
2020-01-20 15:09 UTC, Gerry
Details
bt Windows (windbg) (43.37 KB, text/plain)
2020-01-20 16:30 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2020-01-20 15:09:06 UTC
Created attachment 157271 [details]
Sample file

Load the attached file and then quit (Ctrl +Q)
The application throws an exception. The file has two linked frame, and a .JPG inserted between two lines of text.
Comment 1 Xisco Faulí 2020-01-20 15:45:22 UTC
Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: fc1f85127968d1c2e0a53dace51bf8a78f9e6ca5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

I do believe this is a duplicate of bug 125352

*** This bug has been marked as a duplicate of bug 125352 ***
Comment 2 Julien Nabet 2020-01-20 16:30:09 UTC
Created attachment 157273 [details]
bt Windows (windbg)

On Win10 with master sources updated today, I could reproduce this.