Bug 130121 - Cannot drag text box or add text afterwards
Summary: Cannot drag text box or add text afterwards
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: corruptProfile
Depends on:
Blocks: Textbox
  Show dependency treegraph
 
Reported: 2020-01-22 13:19 UTC by sdc.blanco
Modified: 2020-01-22 17:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-01-22 13:19:17 UTC
Insert>Textbox, and add text
  - Select (try to drag)
  - Select (try to add/edit text)

Actual result:  Not possible to move or add/edit text.

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 6a308d2bfaf1d756aa4cfca6a40b80cf5e88e5fa
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: da-DK (en_DK); UI-Language: en-US
Calc: threaded

Additional information.
1. Can resize
2. Works in 6.3.4.2
Comment 1 Dagmara 2020-01-22 15:40:23 UTC
I can't confirm in:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: CL
Comment 2 Durgapriyanka 2020-01-22 15:44:48 UTC
Thank you for reporting the bug. Works well in 

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 ian 2020-01-22 15:49:39 UTC
I, too, experience no issues with performing the specified actions. 

Using: 

Version: 6.5.0.0.alpha0+ (x64)
Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 4 sdc.blanco 2020-01-22 16:00:27 UTC
Thanks to all the testers.

Comment #1 and comment #3, use the same build
> Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8
My version is built on 21. january.  Have re-tested and still have problem.
> Version: 6.5.0.0.alpha0+ (x64)
> Build ID: 6a308d2bfaf1d756aa4cfca6a40b80cf5e88e5fa
Is Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8 built before or after 21 January?
Comment 5 ian 2020-01-22 16:05:39 UTC
(In reply to sdc.blanco from comment #4)
> Thanks to all the testers.
> 
> Comment #1 and comment #3, use the same build
> > Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8
> My version is built on 21. january.  Have re-tested and still have problem.
> > Version: 6.5.0.0.alpha0+ (x64)
> > Build ID: 6a308d2bfaf1d756aa4cfca6a40b80cf5e88e5fa
> Is Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8 built before or after
> 21 January?

The build beginning with "da7..." was built today, 1-22.
Comment 6 sdc.blanco 2020-01-22 16:37:22 UTC
More detailed instructions

0.  New Document
1.  Insert>Textbox,  write some text in box.
2.  Click outside of Textbox.
3.  Open Navigator (F5)
4.  Double-click on Shape1  (under Drawing objects)
5.  Textbox should be highlighted
6.  Try to move textbox or add text.

Still cannot do it, now with 22. jan. build

Version: 6.5.0.0.alpha0+ (x64)
Build ID: da70fd1edc211bf63f8388e11c1bd8dd398fdaf8
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: da-DK (en_DK); UI-Language: en-US
Calc: threaded
Comment 7 Xisco Faulí 2020-01-22 16:40:54 UTC
I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: a821d89646ef25428cf5992f86d8f31581313bdb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

did you reset the profile ?
Comment 8 Xisco Faulí 2020-01-22 16:51:00 UTC
I can't reproduce steps from comment 6 either. Please try with a clean profile
Comment 9 sdc.blanco 2020-01-22 17:00:04 UTC
(In reply to Xisco Faulí from comment #8)
> I can't reproduce steps from comment 6 either. Please try with a clean
> profile

Profile problem.  Can drag and edit textbox if I restart in Safe-Mode (with Factory Settings or Last known working state).
Comment 10 Xisco Faulí 2020-01-22 17:05:14 UTC
Good. Closign as RESOLVED NOTABUG