Bug 130127 - VLC plugin X11: clicking on a file in the Open File dialog puts garbage in the File input field
Summary: VLC plugin X11: clicking on a file in the Open File dialog puts garbage in th...
Status: RESOLVED DUPLICATE of bug 131898
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-22 16:50 UTC by Eltomito
Modified: 2020-05-03 11:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of a malfunction of the Open File dialog with the X11 VCL plugin (94.01 KB, image/png)
2020-01-22 16:50 UTC, Eltomito
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eltomito 2020-01-22 16:50:47 UTC
Created attachment 157332 [details]
Screenshot of a malfunction of the Open File dialog with the X11 VCL plugin

When I use the X11 VCL plugin on Linux, clicking on a file in the Open File dialog puts not only the filename but also all the other information next to it (human-readable file-type description, creation date...) in the file input box which results in an invalid file name.

Steps to reproduce:

1) Use the X11 VCL plugin:
export SAL_USE_VCLPLUGIN=gen; libreoffice6.5

2) File -> Open (CTRL+O}

3) Click on a file name in the Open File Dialog, e.g. 'whatever.docx'

expected result:
The File field should say 'whatever.docx'

actual result:
The File field says: 'whatever.docx MS Word document 9616 Bytes 01/22/2020, 17:39'

See the attached screenshot.

This is the LO version used:

Version: 6.5.0.0.alpha0+
Build ID: b203b9c83d0000c8465dcd92fb6b029a2f28c724
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-01-14_09:44:21
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Kevin Suo 2020-01-30 10:07:09 UTC
I confirm this with
Version: 6.5.0.0.alpha0+, Build ID: 161d533adf3c2ba1321c0fb0adf863eb766fb5ae, VCL: x11

Bug already exists in  5.4.0.0.alpha1+, 9feb7f7039a3b59974cbf266922177e961a52dd1.
Comment 2 Kevin Suo 2020-01-30 10:09:40 UTC
Set component to LibreOffice as bug also appears in Calc.
Comment 3 Buovjaga 2020-05-03 11:53:13 UTC
(In reply to Kevin Suo from comment #1)
> Bug already exists in  5.4.0.0.alpha1+,
> 9feb7f7039a3b59974cbf266922177e961a52dd1.

Closing as dupe of bug 131898, even though it appears only with 6.4.0.0 cycle

*** This bug has been marked as a duplicate of bug 131898 ***