Bug 130149 - Text using the Cantarell variable font is not printed or PDF exported in some Linux (comment 8 and comment 26)
Summary: Text using the Cantarell variable font is not printed or PDF exported in some...
Status: CLOSED DUPLICATE of bug 108497
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.2.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering PDF-Export
  Show dependency treegraph
 
Reported: 2020-01-23 18:41 UTC by pgkos
Modified: 2022-09-21 19:19 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Writer file with two lines: 1st line in Cantarell, 2nd line in Liberation Sans. (8.86 KB, application/vnd.oasis.opendocument.text)
2021-10-04 23:58 UTC, sax.on.the.beach
Details
Corresponding pdf file. The Cantarell line is not visible but ctrl-c-able. (10.71 KB, application/pdf)
2021-10-04 23:59 UTC, sax.on.the.beach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pgkos 2020-01-23 18:41:33 UTC
Description:
Any text using the Cantarell font Regular or Bold (thin/ultra light is printed correctly) is not printed at all from any LibreOffice application.

Also, that text is missing when exporting to PDF or printing to a PDF file.

The bug is present on Arch Linux - libreoffice-fresh (v6.3.4.2.0+) package.
libreoffice-still (6.2.8) works correctly.

Steps to Reproduce:
1. Open e.g. LibreOffice Writer.
2. Write some text using the Cantarell font, regular or bold.
3. Try to export the document to PDF or print it.

Actual Results:
The PDF document is empty / nothing is printed.

Expected Results:
The text is printed correctly.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Timur 2020-02-07 10:22:16 UTC
"Cantarell is the default typeface supplied with the user interface of GNOME since version 3.0, replacing Bitstream Vera and DejaVu."
I just tested in Windows with PDF export and no repro.
Surely needs testing in Linux.
Until someone else does it, please test with master LO from https://dev-builds.libreoffice.org/daily/master/ or, more easy but less current, from https://libreoffice.soluzioniopen.com/index.php/daily-version/.
Comment 2 Ville Aakko 2020-03-30 08:03:39 UTC
I can reproduce this on libreoffice-fresh 6.4.2-1 (Arch Linux).

Also I can reproduce this with the appimage LibreOfficeDev-daily-x86_64.AppImage.
Comment 3 Timur 2020-03-31 06:57:40 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-04-02 14:29:51 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2020-04-03 20:26:10 UTC
Bibisected with Linux 6.3 repo to https://git.libreoffice.org/core/+/1fc306203b047e79d5b3f30cf615609f80b62fe4%5E!/

Make Noto Color Emoji font work on Linux

However, the commit message says "Make sft.cxx:doOpenTTFont() accept non-outline fonts, the text will not show in PDF but that is not worse than the status quo."

Khaled: what's up with this not being a problem on Ubuntu?
Comment 6 خالد حسني 2020-04-04 14:47:04 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2020-04-04 15:32:21 UTC Comment hidden (obsolete)
Comment 8 خالد حسني 2020-04-04 18:05:37 UTC
(In reply to Buovjaga from comment #7)
> (In reply to Khaled Hosny from comment #6)
> > Are the system affected using the variable version of the font, the one with
> > CFF2 table? (there would be a single font file in this case instead of a
> > separate font file per style).
> 
> https://www.archlinux.org/packages/extra/any/cantarell-fonts/
> https://git.archlinux.org/svntogit/packages.git/tree/trunk/
> PKGBUILD?h=packages/cantarell-fonts

usr/share/fonts/cantarell/Cantarell-VF.otf

That is the variable font with CFF2, if this ends up being used then we wouldn't reject it as we used to. We don't support variable fonts in PDF and printing and should have rejected them, the change mentioned just makes it worse for some kinds of these fonts but that is not the root cause.
Comment 9 qsmfjqsdmflqkj 2020-06-10 18:20:36 UTC
Also affected on Fedora 32 :(.

Version : 6.4.4.2
Build ID : 6.4.4.2-2.fc32
Threads CPU : 4; OS : Linux 5.6; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Comment 10 Risto 2020-06-16 11:52:43 UTC Comment hidden (no-value)
Comment 11 Risto 2020-06-17 22:53:23 UTC Comment hidden (no-value)
Comment 12 Matteo B. 2020-10-28 12:09:04 UTC
I had the same issue yesterday, on Manjaro (5.8.16-2-MANJARO), with libreoffice-fresh (only tried in Impress export/print to PDF) version .
I also noticed that Cantarell is exported/printed only when Italic and Bold are enabled together on the text.

I managed to solve it today by reinstalling the current libreoffice "still" version (6.4.6.2).
Comment 13 Andy Pillip 2021-03-26 07:58:00 UTC
I cannot reproduce in Impress 7.0.5.2 on Fedora 33.
Comment 14 Timur 2021-04-14 10:41:30 UTC Comment hidden (obsolete)
Comment 15 Buovjaga 2021-04-14 12:14:46 UTC Comment hidden (obsolete)
Comment 16 sax.on.the.beach 2021-10-04 23:58:17 UTC
Created attachment 175516 [details]
Writer file with two lines: 1st line in Cantarell, 2nd line in Liberation Sans.
Comment 17 sax.on.the.beach 2021-10-04 23:59:20 UTC
Created attachment 175517 [details]
Corresponding pdf file. The Cantarell line is not visible but ctrl-c-able.
Comment 18 sax.on.the.beach 2021-10-05 00:18:10 UTC
Unfortunately my up-to-date arch systems are affected from the bug. tested on two systems with kernel 5.14.8. i tried writer and calc, both are affected. and i tried the following libreoffice versions (from arch repo) without success:

- 7.1.5
- 7.1.6
- 7.2.1

packages on my systems related to libreoffice are:

libcdr 0.1.7-2
libreoffice-still 7.1.6-1
libreoffice-still-de 7.1.6-1
hunspell 1.7.0-3
hunspell-de 20161207-7
Comment 19 Buovjaga 2021-10-05 05:19:03 UTC
Hmm, I can indeed reproduce the problem, not sure what was happening at the time of my comment 15.

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 0b81761c86786eeb035f857f549d75f143e491ad
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 30 September 2021
Comment 20 InFerNo_ 2021-10-27 07:18:43 UTC
I have the same issue.

I made a presentation with Cantarell and Source Code Pro fonts. Only Source Code Pro is printed.

The Cantarell text is used in various places and sizes.

I'm running Arch Linux on x86_64. 

Version: 7.2.2.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.14; UI render: default; VCL: gtk3
Locale: nl-BE (en_US.UTF-8); UI: en-US
7.2.2-1
Calc: threaded

GNOME 40.4.0 on Xorg


I have copied the .odp Presentation to a Windows machine and the export works correctly there. The fonts are exported to PDF and printed.

It is running Windows 10 Professional on x86_64.

Version: 7.2.2.2 (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: nl-BE (nl_BE); UI: en-US
Calc: threaded

I have installed the Cantarell font for this Windows installation from https://fonts.google.com/specimen/Cantarell
Comment 21 Timur 2021-10-27 15:36:56 UTC
*** Bug 145306 has been marked as a duplicate of this bug. ***
Comment 22 phv 2021-12-22 13:40:44 UTC
*** Bug 146355 has been marked as a duplicate of this bug. ***
Comment 23 Axel Braun 2022-01-25 12:24:51 UTC
Confirmed in 
Version: 7.2.5.1 / LibreOffice Community
Build ID: 20(Build:1)
CPU threads: 12; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

Operating System: openSUSE Tumbleweed 20220122
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.1-1-default (64-bit)
Graphics Platform: X11
Comment 24 Axel Braun 2022-01-27 07:52:33 UTC
...and the bug *does not* appear on 

Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-59.40-default

using

Version: 7.1.4.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 2; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded
Comment 25 Axel Braun 2022-05-31 07:15:21 UTC
Just stumbled over this issue again in 
Operating System: openSUSE Tumbleweed 20220525
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.2
Kernel Version: 5.17.9-1-default (64-bit)
Graphics Platform: X11
Graphics Processor: Mesa Intel® UHD Graphics 630

LO Version: 7.3.3.2 / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 12; OS: Linux 5.17; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 26 Matt Johnson 2022-06-09 01:16:05 UTC
I am able to reproduce this bug on Archlinux with the following configuration:
libreoffice 7.2.7-2 
cantarel-fonts 1:0.303.1-1

The cantarell fonts package is from Gnome's upstream at  https://gitlab.gnome.org/GNOME/cantarell-fonts . The package uses a single installed system font with combined styles at /usr/share/fonts/cantarell/Cantarell-VF.otf

If I remove this system font, rebuild the font cache, and then install Cantarell from Google Fonts (https://fonts.google.com/specimen/Cantarell) as a set of 4 .ttf files (for regular, bold, italic, and BoldItalic, libreoffice works correctly and is able to render the PDF.

Just installing the google font ttf versions alongside the system otf was not sufficient, and still resulted in broken PDF rendering (text in Cantarell is copy-pastable but not visible in the PDF). Let me know if there's any debug information I can help capture to figure out what's going on here.
Comment 27 Timur 2022-06-09 13:34:27 UTC
I retested this in new Ubuntu 22.04 Wayland. Cantarell wasn't installed so I installed manually. Bug wasn't reproduced. 
Repro in openSUSE Tumbleweed.
I amend the title. It's not about any Cantarell, but variable font.
Comment 28 V Stuart Foote 2022-07-01 13:33:41 UTC
(In reply to Timur from comment #27)
> I retested this in new Ubuntu 22.04 Wayland. Cantarell wasn't installed so I
> installed manually. Bug wasn't reproduced. 
> Repro in openSUSE Tumbleweed.
> I amend the title. It's not about any Cantarell, but variable font.

making this pretty clearly another duplicate of bug 103596 enhancement to support use of OpenType variable fonts (OTVF).
Comment 29 V Stuart Foote 2022-07-01 13:34:03 UTC

*** This bug has been marked as a duplicate of bug 103596 ***
Comment 30 schriftarten123 2022-07-18 01:38:33 UTC Comment hidden (spam)
Comment 31 خالد حسني 2022-09-20 10:08:51 UTC

*** This bug has been marked as a duplicate of bug 108497 ***
Comment 32 Buovjaga 2022-09-21 19:17:21 UTC
Khaled: let's keep as closed because this has attracted spam and we have automated measures in place targeting closed statuses.
Comment 33 خالد حسني 2022-09-21 19:19:40 UTC
I see, sorry for the noise (it looked scary in the bug list with the crossed out text).