Bug 130156 - Writer: Add alignment controls to the sidebar for selected objects/shapes/images
Summary: Writer: Add alignment controls to the sidebar for selected objects/shapes/images
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-23 22:56 UTC by andreas_k
Modified: 2020-08-24 21:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Alignment commands in the sidebar (38.86 KB, image/png)
2020-02-17 15:58 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-01-23 22:56:39 UTC
The Position and Size Sidebar panel show the Arrange options and there would be space on the second column next to Arrange: for Align: commands.

Yes we can talk why the Arrange commands are in the Position and Size Sidebar but as they are, than add Align would be consequent.
Comment 1 Xisco Faulí 2020-02-17 15:54:54 UTC
hello Andreas,
Could you please attach a screenshot of the described problem ?
Comment 2 andreas_k 2020-02-17 15:58:28 UTC
Created attachment 157954 [details]
Alignment commands in the sidebar
Comment 3 Xisco Faulí 2020-02-17 16:09:59 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 28d844a589e52abfe62dc66b888e78665221ba28
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded


Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
Comment 4 andreas_k 2020-02-17 20:10:00 UTC
what do you mean you can't reproduce it?

the align commands are not available in the sidebar but as the arrange commands are there I don't see any reason why not add the alignment commands at least when you select more than one shape/objects, ...
Comment 5 QA Administrators 2020-02-18 02:34:04 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2020-02-18 11:50:43 UTC
I expected to see the label 'Align' in the sidebar that why I said I couldn't reproduce it. Changing to enhancement then
Comment 7 Heiko Tietze 2020-02-19 12:58:00 UTC
Do you want to add all seven or just the four horizontal options?
Comment 8 Heiko Tietze 2020-02-19 13:03:30 UTC
(In reply to Heiko Tietze from comment #7)
> Do you want to add all seven or just the four horizontal options?

.uno.ObjectAlign would replicate what's on the toolbar.
Comment 9 andreas_k 2020-02-19 13:05:31 UTC
> .uno.ObjectAlign would replicate what's on the toolbar.

As Align do.
Comment 10 Cor Nouws 2020-02-27 13:42:42 UTC
+1
Comment 11 Heiko Tietze 2020-02-27 14:29:31 UTC
We discussed the idea in the design meeting and welcome the patch.
Comment 12 Commit Notification 2020-04-22 15:58:05 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/90e73c8cb949e2ef96e9a77b2208f53e5feab3ab

tdf#130156 add alignment commands to the sidebar

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.