Bug 130170 - New Style from Selection action needs documentation
Summary: New Style from Selection action needs documentation
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Sidebar-UI-UX Styles-Dialog Help-Link
  Show dependency treegraph
 
Reported: 2020-01-24 12:16 UTC by sdc.blanco
Modified: 2021-01-29 17:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-01-24 12:16:26 UTC
1. Styles>New Style from Selection
2. Click Help Button (in popup dialog box)
3. Styles Sidebar (F11)
4. Click Styles icon (top right corner of Styles window) – New Style from Selection
5  Click Help Button (in popup dialog box)

Actual results:
step 1.  Dialog box populated with all paragraph styles
step 2.  new Help overview page
step 4.  Dialog box populated with custom paragraph styles
step 5.  new Help overview page

Expected results.
Step 1 and 4:   ?? should they be different?
Step 2 and 5:   relevant help pages

Additional information
https://help.libreoffice.org/latest/en-US/text/shared/01/05140100.html  
(consistent with step 4.  Page needs access commands added)
Comment 1 sdc.blanco 2020-01-24 12:29:41 UTC
"inconsistency" part is probably a duplicate of bug 126352 -- so revise this bug 130170 to be a report about the Help button and documentation problem.
Comment 2 Xisco Faulí 2020-01-28 11:34:43 UTC
(In reply to sdc.blanco from comment #1)
> "inconsistency" part is probably a duplicate of bug 126352 -- so revise this
> bug 130170 to be a report about the Help button and documentation problem.

Changing Component to Documentation then
Comment 3 Dieter 2020-07-19 15:52:31 UTC
There is also help page about New Style from Selection [1]. So I think it would be better, if this is taeget of help-button and informations form [2] are integrated into that page.


[1] https://help.libreoffice.org/6.4/en-GB/text/swriter/guide/stylist_fromselect.html?&DbPAR=WRITER&System=WIN

[2] https://help.libreoffice.org/6.4/en-GB/text/shared/01/05140100.html?System=WIN&DbPAR=WRITER&HID=sfx/ui/newstyle/dialog-action_area3#bm_@@nowidget@@
Comment 4 Commit Notification 2020-12-17 23:15:10 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/421d76024ce554072d3e062345eeaa32e735f3c6

tdf#130170  - add related topic to Create Style
Comment 5 sdc.blanco 2020-12-17 23:38:23 UTC
(In reply to Commit Notification from comment #4)
> tdf#130170  - add related topic to Create Style
Not exactly a resolution.  More like a "workaround" - so that users have a better chance to find something useful.

Summary of what is needed:

1.  Help button for "Styles>New Style from Selection" dialog box goes to:

https://help.libreoffice.org/7.2/en-US/text/shared/01/05140100.html

which does not give any real help -- but patch now adds a related topic section with a link to:

https://help.libreoffice.org/7.2/en-US/text/swriter/guide/stylist_update.html

which gives an explanation. 

2.  https://help.libreoffice.org/7.2/en-US/text/swriter/guide/stylist_update.html

overlaps somewhat with:

https://help.libreoffice.org/7.2/en-US/text/swriter/guide/stylist_fromselect.html

Maybe those pages should be combined and coordinated with shared/01/05140100.xhp
Comment 6 Commit Notification 2020-12-28 12:20:52 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/787dd690a7fd636c22f24b5561e9ba93503f56de

tdf#130170 update and elaborate Create Style dialog help
Comment 7 Commit Notification 2020-12-28 16:07:11 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/f1e2ee29e7eab68452fd345127a3d14ba0958c77

Resolves: tdf#130170 update help on "new styles from selection"
Comment 8 sdc.blanco 2020-12-28 16:13:06 UTC
Now https://help.libreoffice.org/7.2/en-US/text/shared/01/05140100.html  is updated so that it is meaningful to use the Help button in the "Create Style" dialog (which has also been updated now to "New Style from Selection").  Also the help has been conditional on which application is being used, because there are differences.

Also updated the guide page for that dialog:
https://help.libreoffice.org/7.2/en-US/text/swriter/guide/stylist_fromselect.html

These updates should make these help pages functionally adequate, so closing as FIXED
Comment 9 Commit Notification 2021-01-14 17:15:03 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/0a848766232d6516f2af5a7605373b2ab8ca193e

tdf#130170 update change in dialog box label
Comment 10 Dieter 2021-01-29 17:56:21 UTC
Looks good. Thanks for fixing it, Seth.

=> VERIFIED FIXED