Bug 130181 - LibreOffice Writer - Automatically Embed Fonts - Enhancement Request
Summary: LibreOffice Writer - Automatically Embed Fonts - Enhancement Request
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2020-01-24 19:32 UTC by stefane.guevremont
Modified: 2020-01-28 08:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word Example - Auto Embed Fonts (4.32 KB, image/png)
2020-01-24 19:35 UTC, stefane.guevremont
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefane.guevremont 2020-01-24 19:32:39 UTC
Description:
It is now possible to embed fonts in One Singular document. 

It would be useful to have an option to automatically embed fonts in each new document (as it is Possible in Ms Word: Options\Save\Preserve fidelity when sharing this document: "All New Documents" ➔ "Embed fonts in the file").

Thanks!

Actual Results:
No global option to automatically embed fonts

Expected Results:
Have a checkbox in the load/save section


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 stefane.guevremont 2020-01-24 19:35:11 UTC
Created attachment 157412 [details]
Word Example - Auto Embed Fonts
Comment 2 V Stuart Foote 2020-01-24 20:58:12 UTC
Can already be set 'per-document' in the Properties... dialog.

The options, found on the 'Font' panel, provide granular control over the font embedding performed.

IMHO it is better to keep this restricted and set 'per-document' and only via the Properties dialog.

An Expert configuration stanza to pre-configure values on the Properties... dialog might be possible--but no GUI widget to set.

Even if it were not by default, enabling font embedding globally would produce a lot of bloated documents. A user error of not checking the 'Only embed fonts that are used in documents'
Comment 3 Mike Kaganski 2020-01-27 06:57:44 UTC
The desired functionality is already available through templates machinery. Just create a template in which the embedding fonts setting is set as required; optionally set the template as default if needed.

I suggest to close it WONTFIX, since there's no benefit in adding an alternative setting to get the same result, which only would add complexity.
Comment 4 Heiko Tietze 2020-01-27 11:05:59 UTC
(In reply to V Stuart Foote from comment #2)
> Even if it were not by default, enabling font embedding globally would
> produce a lot of bloated documents.

(In reply to Mike Kaganski from comment #3)
> I suggest to close it WONTFIX...

Agreed
Comment 5 stefane.guevremont 2020-01-27 23:59:14 UTC
Whoa, I just tested a couple of fonts, and yes, we are in agreement about size increase. Conversely, would an option like "Embed only characters used in document" be an available option, or an interesting feature to suggest?
Comment 6 Mike Kaganski 2020-01-28 06:04:15 UTC
(In reply to stefane.guevremont from comment #5)
> Conversely, would an option like "Embed only characters used in
> document" be an available option, or an interesting feature to suggest?

While *that* would be a valid enhancement (in the sense that it's missing from the suite; and that there are use cases for it), personally I would oppose that suggestion. Embedding a font only partly effectively makes documents kind of "read-only": on the target system, where the font is not installed, the document would be rendered fine, but editing it would be either disabled (because fonts in it don't allow to use other glyphs), or impaired (because any glyph not embedded would use a substitution). IMO, an electronic document in native format is meant for possible future edition; and font embedding should not decrease its functionality. OTOH, there are formats specifically created for archiving purposes: PDF only embeds glyphs used in the document, just what you want.
Comment 7 Heiko Tietze 2020-01-28 08:26:09 UTC
FWIW, the design team made a proposal about font substitution in [1]. See also 

* bug 103342 [META] Font substitution bugs and enhancements  
* bug 78186 Add an easy way to know which fonts are used in a document and which of them are missing  
* bug 105318 Behavior of Special Character dialog on launch when font at edit cursor is not installed and fallback occurs  
* bug 96872 Make it more obvious that a font has been substituted (see comment 12)  
* bug 104667 Font substitution mechanism for import formats  
* bug 113496 Open source font installer bundles on download webpage per locale 

[1] https://design.blog.documentfoundation.org/2016/10/21/dealing-with-missing-fonts/