Bug 130220 - HANG: pasting content
Summary: HANG: pasting content
Status: RESOLVED DUPLICATE of bug 130685
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-01-27 13:11 UTC by Xisco Faulí
Modified: 2020-06-19 09:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-01-27 13:11:10 UTC
Steps to reproduce:
1. Open attachment 81738 [details] from bug 58595
2. Select all
3. Copy
4. Paste

-> LibreOffice hangs

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 6b4fe3e44b4daa89fef6a3385919b00472eaed60
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-01-27 13:12:42 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fa5eb82b398e29ae033f7b7c8c8195dfc10cf5b0

author	László Németh <nemeth@numbertext.org>	2019-07-25 17:52:20 +0200
committer	László Németh <nemeth@numbertext.org>	2019-08-01 09:43:51 +0200
commit	fa5eb82b398e29ae033f7b7c8c8195dfc10cf5b0 (patch)
tree	0969d7c1608393a4bdd565618ff791e1b7cd72a6
parent	1aac73a1fb260e4c76a483a68f003913fdd2c4bb (diff)
tdf#118699 change tracking: don't number empty lines

Bisected with: bibisect-linux64-6.4

Adding Cc: to László Németh
Comment 2 Xisco Faulí 2020-06-17 17:04:15 UTC
Also reproduced with attachment 160662 [details] from bug 132944
Comment 3 Xisco Faulí 2020-06-17 17:24:01 UTC
oh, this is interesting, the issue is only reproducible with gtk3

Not reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 27381dc1b76e4aee5459b3d85e6fc5919d2b8f98
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, I thought you might be interested in this issue
Comment 4 Caolán McNamara 2020-06-17 18:17:54 UTC
without looking at it, "only happens under gtk" could be "only happens with a11y enabled"
Comment 5 Caolán McNamara 2020-06-18 20:30:18 UTC
hmm, for me in master under gtk3 under X or wayland

ctrl+a, ctrl+c, ctrl+v

doesn't give me a hang in master or 7-0. Did I use the right way to reproduce ?
Comment 6 Xisco Faulí 2020-06-19 09:13:04 UTC
Ok, so there are two problems with two documents pointing to the same commit.
The problem described in the description was fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=166b5010b402a41b192b1659093a25acf9065fd9, thus this issue can be closed as a duplicate of bug 130685.
The other problem is still reproducible in master and I'll report it in a different issue

*** This bug has been marked as a duplicate of bug 130685 ***