Download it now!
Bug 130286 - Crash in: SwDrawTextShell::Execute(SfxRequest &)
Summary: Crash in: SwDrawTextShell::Execute(SfxRequest &)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.1
Keywords: bibisected, bisected, needUITest, regression
: 129202 130195 130296 130398 130403 130463 130465 130557 130561 130591 130627 130740 130787 130789 130818 130867 130870 130882 130956 131048 131087 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-30 11:51 UTC by Xisco Faulí
Modified: 2020-03-05 10:58 UTC (History)
24 users (show)

See Also:
Crash report or crash signature: ["SwDrawTextShell::Execute(SfxRequest &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-01-30 11:51:43 UTC
Steps to reproduce:
1. Open attachment 136418 [details] from bug 112543
2. Double click on the textbox
3. Right click on the hyperlink - Edit hyperlink

-> Crash

Reproduced in

Versión: 6.4.0.3 (x86)
Id. de compilación: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Subprocs. CPU: 2; SO: Windows 6.1 Service Pack 1 Build 7601; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 1 Xisco Faulí 2020-01-30 11:59:44 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=77cc0e929ee331af6b97b65e9b6ec5400ef05cd4. Backporting it to libreoffice-6-4
Comment 3 Commit Notification 2020-01-30 16:39:19 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/dc9b1ee0a5144ce182407d10466eab682f7da62a

tdf#130286: jsdialogs: fix CID 1455691 & CID 1455690

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-01-30 16:59:28 UTC
*** Bug 130296 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2020-01-30 17:01:38 UTC
*** Bug 129202 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2020-02-04 15:53:43 UTC
*** Bug 130403 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2020-02-04 16:21:43 UTC
*** Bug 130398 has been marked as a duplicate of this bug. ***
Comment 8 Maxim Monastirsky 2020-02-06 09:51:39 UTC
*** Bug 130463 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2020-02-06 17:51:24 UTC
*** Bug 130465 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2020-02-10 14:20:34 UTC
*** Bug 130557 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2020-02-10 14:43:10 UTC
*** Bug 130561 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2020-02-11 16:10:03 UTC
*** Bug 130591 has been marked as a duplicate of this bug. ***
Comment 13 Ming Hua 2020-02-12 20:52:52 UTC
*** Bug 130627 has been marked as a duplicate of this bug. ***
Comment 14 Xisco Faulí 2020-02-14 16:13:09 UTC
*** Bug 130195 has been marked as a duplicate of this bug. ***
Comment 15 Ming Hua 2020-02-16 09:54:12 UTC
*** Bug 130703 has been marked as a duplicate of this bug. ***
Comment 16 Xisco Faulí 2020-02-18 10:18:17 UTC
*** Bug 130740 has been marked as a duplicate of this bug. ***
Comment 17 Maxim Monastirsky 2020-02-20 11:04:15 UTC
*** Bug 130787 has been marked as a duplicate of this bug. ***
Comment 18 Maxim Monastirsky 2020-02-20 11:13:38 UTC
*** Bug 130789 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2020-02-20 19:51:59 UTC
*** Bug 130818 has been marked as a duplicate of this bug. ***
Comment 20 Oliver Brinzing 2020-02-22 16:53:54 UTC
*** Bug 130870 has been marked as a duplicate of this bug. ***
Comment 21 Maxim Monastirsky 2020-02-22 19:39:19 UTC
*** Bug 130867 has been marked as a duplicate of this bug. ***
Comment 22 Sebi 2020-02-23 10:04:35 UTC
Not totally fixed, it doesn't crash now but i still can't align text inside text box, clicking align doesn't do anything.
Comment 23 Maxim Monastirsky 2020-02-23 10:15:32 UTC
(In reply to Sebi from comment #22)
> Not totally fixed, it doesn't crash now but i still can't align text inside
> text box, clicking align doesn't do anything.
The final 6.4.1 build will include a fix for that part too. See Bug 130482.
Comment 24 Maxim Monastirsky 2020-02-23 12:23:22 UTC
*** Bug 130882 has been marked as a duplicate of this bug. ***
Comment 25 Xisco Faulí 2020-02-26 13:30:59 UTC
*** Bug 130956 has been marked as a duplicate of this bug. ***
Comment 26 Oliver Brinzing 2020-03-01 12:38:13 UTC
*** Bug 131048 has been marked as a duplicate of this bug. ***
Comment 27 Xisco Faulí 2020-03-03 11:07:31 UTC
*** Bug 131087 has been marked as a duplicate of this bug. ***
Comment 28 Xisco Faulí 2020-03-05 10:58:00 UTC Comment hidden (obsolete)