Bug 130290 - Roman page numbers all over sections .docx
Summary: Roman page numbers all over sections .docx
Status: RESOLVED DUPLICATE of bug 129353
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-30 12:50 UTC by Marco A.G.Pinto
Modified: 2020-01-30 13:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample .docx (389.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-01-30 12:50 UTC, Marco A.G.Pinto
Details
The example file in 6.4RC1 and current master (129.83 KB, image/png)
2020-01-30 13:12 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2020-01-30 12:50:52 UTC
Created attachment 157527 [details]
Sample .docx

Hello!

I have attached a sample of my thesis where it doesn't respect the page numbers style over sections.

It uses Roman all over, even after it was supposed to use Arab numbers.
Comment 1 Xisco Faulí 2020-01-30 13:10:23 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=5cdb14345842c07eb1a466897753da910e9488f8.
Closing as duplicate of bug 129353

*** This bug has been marked as a duplicate of bug 129353 ***
Comment 2 Xisco Faulí 2020-01-30 13:11:22 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.19; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 3 NISZ LibreOffice Team 2020-01-30 13:12:26 UTC
Created attachment 157528 [details]
The example file in 6.4RC1 and current master

Repro with:

Version: 6.4.0.1 (x86)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

But not with: 
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 5d7a526ee784abc3d83835b9e43047baf5dbe0b9
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: CL

Page 16 has page number "2" instead of "xii".