Download it now!
Bug 130323 - Fileopen: Loosing image on 2nd slide copy/pasted from 1st slide
Summary: Fileopen: Loosing image on 2nd slide copy/pasted from 1st slide
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OOXML-SmartArt
  Show dependency treegraph
 
Reported: 2020-01-31 13:55 UTC by Irakli Lomidze
Modified: 2020-02-09 20:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File Demonstrating image copy / paste issue (79.79 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-01-31 13:56 UTC, Irakli Lomidze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Irakli Lomidze 2020-01-31 13:55:30 UTC
Description:
I have image from slide #1 than I have copy it another slide,
In Microsoft PowerPoint it works fine,
In Impress I don't have a copyed image.

Document created in PowerPoint 365.

Steps to Reproduce:
Please see attached file

Actual Results:
Please see attached file

Expected Results:
Please see attached file


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Irakli Lomidze 2020-01-31 13:56:10 UTC
Created attachment 157559 [details]
File Demonstrating image copy / paste issue
Comment 2 Durgapriyanka 2020-01-31 15:52:56 UTC
Thank you for reporting the bug. I can not reproduce this in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

But, can reproduce in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Irakli Lomidze 2020-01-31 16:18:32 UTC
I just sad how that slides was created in ms PowerPoint.

just open attached file in PowerPoint and then open it in Impress you will see that image is disrepair in slide 2 (in impress).
Comment 4 ian 2020-02-01 16:05:46 UTC
Thank you for reporting the bug. I can replicate this bug in a recent master build on Windows. 

Version: 7.0.0.0.alpha0+ (x64)
Build ID: e8ac78d3afdeb0302eaea34a50f1ca912d5fe897
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

I can, additionally, replicate this bug in a recent master build on Linux.

Version: 7.0.0.0.alpha0+
Build ID: 4ff12ba6f4639c73587f2bb58afcc3ca6fb30105
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-01-24_21:09:14
Locale: es-ES (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I have set the status to "NEW".
Comment 5 Timur 2020-02-06 17:09:08 UTC
No repro 6.1. Repro 6.2 and 7.0+. Seems regression.
Comment 6 Aron Budea 2020-02-09 20:49:49 UTC
Bibisected to the following commit using repo bibisect-linux-64-6.3, apparently it's SmartArt-related. Adding CC: to Grzegorz Araminowicz.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e9986153e44d7ec6ca9c5f1373971de74dcbacda
author		Grzegorz Araminowicz <grzegorz.araminowicz@collabora.com>	2019-03-14 08:25:12 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2019-03-14 14:04:02 +0100

PPTX import: import SmartArt drawing into single GroupShape