Bug 130325 - When navigating validity dropdown using the arrow keys, the first option from the list is chosen right away
Summary: When navigating validity dropdown using the arrow keys, the first option from...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:7.0.0 target:6.3.6 target:6.4.2
Keywords: bibisected, bisected, regression
: 130643 130854 130873 131039 131052 131857 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-31 14:07 UTC by Getafix
Modified: 2020-04-04 14:43 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample attached (16.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-01-31 14:12 UTC, Getafix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Getafix 2020-01-31 14:07:56 UTC
Description:
LibreOffice 6.4.0.3_x64, Calc, Regression, when choosing from drop down using KEYBOARD, instead of letting scroll to desired option and choosing with a Enter it chooses and enters the first option from the drop down list

Steps to Reproduce:
1. There are a list of names in a column
2. Press ALT+Down Arrow (Validation option also)
3. It shows the list of names in that column
4. Choose the down arrow key to scroll
5. Instead of letting you scroll (and choose with ENTER), it will choose and enter the first option from the drop down list

Actual Results:
Will choose the first option/name from the drop down list

Expected Results:
should let you scroll through the list and let you choose the desired option with ENTER


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Getafix 2020-01-31 14:12:48 UTC
Created attachment 157562 [details]
Sample attached

Sample attached
Comment 2 Ming Hua 2020-01-31 15:52:25 UTC
Reproduced in 6.3.5 RC1 with the attached example:
版本: 6.3.5.1 (x64)
Build ID: 9a62adaf9abe90e8fef419f29114b0176dd66801
CPU 线程: 2; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded

... but can not reproduce in 6.2.8:
Version: 6.2.8.2 (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

So set to NEW and add keywords.
Comment 3 Aron Budea 2020-02-01 11:00:13 UTC
Bibisected to the following commit using repo bibisect-linux-64-6.5. Adding CC: to Samuel Mehrbrodt.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7de9417d5f65d35227c7f80f6d587c2a56bde4e0
author		Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-11-27 16:43:19 +0100
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-11-28 11:20:23 +0100

tdf#129043 Correctly deliver combo box events when used with keyboard
Comment 4 Commit Notification 2020-02-13 09:17:22 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d92463c88a557eea7a439def39659b1409772583

tdf#130325 Fix listbox used as dropdown

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-02-14 14:23:19 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/f475d0574a2df630b2940f0204bb13199f823706

tdf#130325 Fix listbox used as dropdown

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-02-14 14:23:31 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1283044a47277e8b3de51c712cd72a0ffec06024

tdf#130325 Fix listbox used as dropdown

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Samuel Mehrbrodt (CIB) 2020-02-14 14:27:07 UTC
*** Bug 130643 has been marked as a duplicate of this bug. ***
Comment 8 Roman Kuznetsov 2020-02-21 21:43:36 UTC
*** Bug 130854 has been marked as a duplicate of this bug. ***
Comment 9 Oliver Brinzing 2020-02-22 17:02:01 UTC
*** Bug 130873 has been marked as a duplicate of this bug. ***
Comment 10 Oliver Brinzing 2020-03-01 12:44:44 UTC
*** Bug 131039 has been marked as a duplicate of this bug. ***
Comment 11 Oliver Brinzing 2020-03-02 17:24:16 UTC
*** Bug 131052 has been marked as a duplicate of this bug. ***
Comment 12 Oliver Brinzing 2020-04-04 14:43:38 UTC
*** Bug 131857 has been marked as a duplicate of this bug. ***