Download it now!
Bug 130327 - Frame in Header problems: only shows on all pages after anchor is changed "to page" and then to any other anchor
Summary: Frame in Header problems: only shows on all pages after anchor is changed "to...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer Frame
  Show dependency treegraph
 
Reported: 2020-01-31 14:10 UTC by sdc.blanco
Modified: 2020-02-21 00:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-01-31 14:10:45 UTC
test A

1. Open new document
2. (make 3 or 4 pages with Ctrl-Enter)
3. Make Header, and set focus outside of Header (in document)
4. Insert>Frame>Frame Interactively  (and put some text)
5. Move Frame out of document body into Header
6. Click in document body and scroll through pages.

Actual result:  Header frame only shown on first page, not on others.
Expected:  frame shown on all pages.

test B

7.  Use navigator to edit frame  (cannot focus on frame with mouse, see bug 130321)
8. Change anchor (in Type tab)  “to page”

Actual result:  Frame appears only in Header where moved 
Expected result:  Frame appears on all pages.

test C

9.  right-click on frame (now you can use mouse) and change anchor “To paragraph” (or “To Character” or “As Character”)

Actual result:  Frame appears in header on all pages.

Additional comments.

0. Hard to summarize results in a simple way - but problems/issues should be clear if procedure is followed.

1. Presumably “To Page” anchor “loses” its relation to Header

2. Note that anchor was “To paragraph” in test A.  But something has happened in setting anchor “to page” and then “to paragraph” again for the frame to be shown on all pages in test C.

Tested with LO 6.3.4.2 

and

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: da-DK (en_DK); UI-Language: en-US
Calc: threaded
Comment 1 sdc.blanco 2020-01-31 15:17:54 UTC
Maybe a frame with "Anchor to Page" in Header area should not be reproduced on each page (i.e., its current behavior).  This allows placing the frame in the header area, without the frame appearing in the header of other pages (i.e., a "feature", not a "bug").  But anchoring the frame to paragraph, to character, or as character in the header should be shown on all pages with the Header.
Comment 2 Dieter 2020-02-16 06:25:01 UTC
(In reply to sdc.blanco from comment #0)
> test A

> 
> Actual result:  Header frame only shown on first page, not on others.
> Expected:  frame shown on all pages.

I confirm the result, but this is, what I expect.

> 
> test B
> 
> Actual result:  Frame appears only in Header where moved 
> Expected result:  Frame appears on all pages.

I confirm the result, but I would only expect, that frame appears on all pages, if focus is in header before editing the frame.

> test C

I confirm the result.


So I agree with the bug summary, but I would only expect this, if focus is in header. Do you agree?
Comment 3 sdc.blanco 2020-02-16 08:19:49 UTC
(In reply to Dieter from comment #2)
> (In reply to sdc.blanco from comment #0)
> > test A
> I confirm the result, but this is, what I expect.
If I write text in the header it shows on all pages, so why would you expect the frame to be shown on only one page, and not all of them, when it is moved into the header? (what have I misunderstood here?)

> > test B
> I confirm the result, but I would only expect, that frame appears on all
> pages, if focus is in header before editing the frame.
How do you determine where the focus is?  In this example, the frame is located in the header.  

But as noted in comment 1, if the frame is anchored to the page, then even though the frame is physically in the Header, it is only shown on the page to which it is anchored. 

(I do not know whether to expect it or not, but given that changing the anchoring -- without moving the position of the frame, causes the frame to appear on all pages -- it seems all right to leave this alternative.)

> I would only expect this, if focus is in header. Do you agree?
I do not know how to determine whether the focus is in the header or not, but in all these cases, I tried to move the frame into header.  And I agree with the idea that "if the frame is in the header, then it should be shown on all pages" (but again with case B and comment 1 as an ambiguous case -- depending on how focus is defined).  In the case of frames, I would assume it depends on the physical position of the frame and not its anchoring.
Comment 4 Dieter 2020-02-20 08:06:07 UTC
(In reply to sdc.blanco from comment #3)
> How do you determine where the focus is?

Perhaps my wording is not correct, but if I put cursor into header (this is what I meant with "focus in header") and move frame as a next step, I would expect, that it effects the header (of all pages). If cursor is in a line of the page and I move the frame as a next step, I would expect, that it doesn't effect the header. (I asume, this also answers your first question and perhaps also the other questions).
Comment 5 sdc.blanco 2020-02-21 00:44:01 UTC
(In reply to Dieter from comment #4)
Thanks.  Now I understand.  This is NAB.
My confusion arose because, I could physically place a frame above the "dotted line" which marks the header.  

But I understand now that the critical feature is not the physical location of the frame, but whether it is "anchored" in the header.

So, it is possible to anchor a frame to a paragraph in the header, but place the frame physically in the middle of the page, and it will be repeated across all the pages.  

Or anchor a frame to a page, but place it in the Header Area (Case B), then then it only shows on the page where anchored.