Download it now!
Bug 130341 - EDITING: Impossible to delete a table from Relationdesign in Linux KDE5
Summary: EDITING: Impossible to delete a table from Relationdesign in Linux KDE5
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.0.0 target:6.4.2
Keywords: bibisectRequest, regression
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-02-01 08:40 UTC by Robert Großkopf
Modified: 2020-02-19 10:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Try to delete the table in relationships-design. (3.26 KB, application/vnd.oasis.opendocument.database)
2020-02-01 08:40 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2020-02-01 08:40:28 UTC
Created attachment 157575 [details]
Try to delete the table in relationships-design.

Open the attached database.
Open Tools > Relationships.
There is one table added.
Click with right mouseclick on the header of the table.
"Delete" will appear - but it is impossible to delete the table.

This bug appears in Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

It appears also in LO 6.4.0.3 on OpenSUSE 15.1 64bit rpm Linux.

It works well, for example, in LO 6.1.5.2 on the same machine. So it's a regression.
Comment 1 Robert Großkopf 2020-02-01 08:45:06 UTC
Tested a little bit more:
works with LO 6.2.6.2, fails with LO 6.3.0.4 on OpenSUSE 15.1 64bit rpm Linux.

The button for deleting the table will disappear after moving the finger from the right mouse button since LO 6.3.
Comment 2 Alex Thurgood 2020-02-04 09:25:04 UTC
No repro for me with

Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
Threads CPU : 4; OS : Mac OS X 10.15.3; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Select table header, right mouse button click, select Delete
Question : are you sure you want to delete the table
Click on : OK
Table is deleted from Relations window.
Close Relations window
Question : Do you want to save your changes ?
Click on : OK

Relations window closes and user is returned to main ODB UI.
Comment 3 Robert Großkopf 2020-02-04 13:43:14 UTC
Have tested it a little bit more: 
Works with 
VCL: x11;
and
VCL: gtk3;

Fails with 
VCL: kde5;

So it's a special problem of kde5 on OpenSUSE 15.1 64bit rpm Linux.
Comment 4 Julien Nabet 2020-02-07 21:42:43 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Indeed with kf5 rendering only.

Michael: thought you might be interested in this one. "Delete" entry appears but can't be selected to remove the table.
Comment 5 Michael Weghorn 2020-02-07 22:43:33 UTC
(In reply to Julien Nabet from comment #4)
> Michael: thought you might be interested in this one. "Delete" entry appears
> but can't be selected to remove the table.

Will take a look, hopefully next week. Implementing native context menus for the qt5 VCL plugin should hopefully fix this issue, along with bug 128921.
Comment 6 Commit Notification 2020-02-12 08:20:13 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1e0b16f8695498e4eea7c2208aabf7e7664ce749

tdf#128921 tdf#130341 tdf#122053 qt5: Native PopupMenus

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Weghorn 2020-02-12 08:24:13 UTC
Fixed on master now, backport for 6.4 pending in Gerrit: https://gerrit.libreoffice.org/c/core/+/88491
Comment 8 Julien Nabet 2020-02-13 21:52:22 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this anymore.
Thank you Michael!
Comment 9 Commit Notification 2020-02-19 10:58:11 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/ceb2f69e0ef2381ce6ed8c65ea45e72aa86cda56

tdf#128921 tdf#130341 tdf#122053 qt5: Native PopupMenus

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.