Download it now!
Bug 130367 - Draw: Move "Color replacer" item from "Tools" menu to "Format-Image-Filter" submenu
Summary: Draw: Move "Color replacer" item from "Tools" menu to "Format-Image-Filter" s...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2020-02-02 21:15 UTC by Roman Kuznetsov
Modified: 2020-02-20 10:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-02-02 21:15:56 UTC
Description:
Move "Color replacer" item from "Tools" menu to "Format-Image-Filter" submenu

because that tool works only for images and doesn't work for any shapes.
It's just a filter.

Steps to Reproduce:
-

Actual Results:
Color replacer is in Tools menu

Expected Results:
Color replacer is in Format-Image-Filter submenu


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Regina Henschel 2020-02-02 22:01:23 UTC
I see no benefit to hide the Color Replacer deep in the Format menu.

Changes to the UI should be avoided, because it produces additional work for the documentation team and displeases long time users.
Comment 2 Heiko Tietze 2020-02-03 10:42:34 UTC
The color replacer works only for images, so Format > Image would indeed be the better place. Is one level less hidden okay for you, Regina?
Comment 3 Regina Henschel 2020-02-03 13:17:26 UTC
(In reply to Heiko Tietze from comment #2)
> The color replacer works only for images, so Format > Image would indeed be
> the better place. Is one level less hidden okay for you, Regina?

It is not only a problem of level. The Color Replacer is not a format on the image, but it changes the image itself. If you want more consistence, then I would go the other way round and move all image tools from Format to Tools. Tools are for me: Compress, Replace, Save, Edit with External Tool, Filter.

There are other means to make visible, that a tool is not applicable to a selected object.

The level in the menus is a problem for accessibility. Menus give access without using the mouse.
Comment 4 Heiko Tietze 2020-02-20 10:37:04 UTC
We discussed the topic in the design meeting. Regina has a point with Image being not something that is formatted. So moving all the items to Tools could be the only way. But on the other hand, users expect consistency and hate when the menu changes. So the decision is to keep the current menu => WFM.