Bug 130379 - International chracters get mutilated in csv export
Summary: International chracters get mutilated in csv export
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV-Export
  Show dependency treegraph
 
Reported: 2020-02-03 10:13 UTC by Jan Toonen
Modified: 2021-05-11 20:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Toonen 2020-02-03 10:13:12 UTC
Description:
I have a MS Excel file whih contains characters like "o (o unlaut). They display correctly in Libreoffice when I import the file. But when I export the file as csv. These characters get a different character code and don't display correly.

Steps to Reproduce:
1. Write in Excel an international character in a worksheet and save file
2. Inmport in Libreoffice and check if character displays coorectly
3. Save as csv and open de scv file in Linux editor like vi. (character is "different".

Actual Results:
strange character code

Expected Results:
same character code


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
apparantly something gts "re-coded" on Linux for uft-8
Comment 1 m.a.riosv 2020-02-03 21:15:20 UTC
Because you need to select the character code when saving.

There is an option on the save dialog to modify 'Edit filter settings"
Comment 2 QA Administrators 2020-08-02 03:40:19 UTC Comment hidden (obsolete)
Comment 3 Roman Kuznetsov 2020-08-28 17:32:50 UTC
Jan, can you say us, if the solution from Comment 1 help you?
Comment 4 Jean-Baptiste Faure 2021-05-11 20:41:44 UTC
It seems that reporter do not want provide requested info. So closing as insufficient data. Please, feel free to reopen if you disagree.

That said, it's clear that comment #1 is the right thing to do.

Best regards. JBF