Bug 130389 - Data ranges dialog, data series tab, move up/down buttons: Reversed actions
Summary: Data ranges dialog, data series tab, move up/down buttons: Reversed actions
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Julien Nabet
URL:
Whiteboard: target:7.0.0 target:6.4.1
Keywords: regression
: 130645 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-03 13:12 UTC by eomanis
Modified: 2020-02-14 08:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the dialog with the affected buttons highlighted (50.16 KB, image/png)
2020-02-03 13:12 UTC, eomanis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eomanis 2020-02-03 13:12:17 UTC
Created attachment 157618 [details]
Screenshot of the dialog with the affected buttons highlighted

LibreOffice Calc, graph editing mode, "Data Ranges" dialog, "Data Series" tab:
The "Move data series up in list" button moves the selected data series down, and the "Move data series down in list" button moves the selected data series up.
Comment 1 Julien Nabet 2020-02-03 20:14:46 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Julien Nabet 2020-02-03 20:47:27 UTC
Let's try with https://gerrit.libreoffice.org/#/c/core/+/87921/
Comment 3 Julien Nabet 2020-02-04 09:46:23 UTC
For the record, I don't reproduce this on Win10 with LO 6.3.4.2
Comment 4 Julien Nabet 2020-02-04 10:28:46 UTC
Regression from:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=6cdab5c92cecf90090ba72dfa6c22edf0d41028f
author	Kelemen Gábor <kelemeng@ubuntu.com>	2019-12-06 11:03:29 +0100
committer	László Németh <nemeth@numbertext.org>	2019-12-12 10:53:51 +0100
commit 6cdab5c92cecf90090ba72dfa6c22edf0d41028f (patch)
tree 96b9a5932fce43970c5835246ef1e21fe3705eae
parent cea1ae2a4f7abdcfc3874d714bdafef801910c1c (diff)
tdf#34517 Bring forward/backward in chart series switched

Gabor: thought you might be interested in this one (I put you in cc of my patch on gerrit).
Comment 5 Commit Notification 2020-02-04 14:32:43 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/93670d6cb7669b41d20feb91309eeb9930c67a27

tdf#130389: Data ranges dialog, data series tab, move up/down reversed

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2020-02-04 14:35:51 UTC
Pending CI https://gerrit.libreoffice.org/c/core/+/87982 for 6-4
Comment 7 Julien Nabet 2020-02-04 14:37:44 UTC
Fix for 6.4 branch on gerrit: https://gerrit.libreoffice.org/#/c/core/+/87982/
Comment 8 Commit Notification 2020-02-05 06:05:46 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7bfe30c2a1c67961777ff52f20eac30a164e8340

tdf#130389: Data ranges dialog, data series tab, move up/down reversed

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2020-02-14 08:53:32 UTC
*** Bug 130645 has been marked as a duplicate of this bug. ***