Download it now!
Bug 130490 - Status bar shows wrong page count when restarting page numbering
Summary: Status bar shows wrong page count when restarting page numbering
Status: RESOLVED DUPLICATE of bug 128626
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2020-02-06 17:02 UTC by sdc.blanco
Modified: 2020-02-07 00:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-02-06 17:02:03 UTC
1. Open new document
2. Insert>More Breaks>Manual Break
3. Choose "Page Break"
4. Choose (any) Style (to activate "Change page number")
5. Check "Change page number"   ("1" is adequate)
6. OK

Statusbar (lower left corner) shows:

Actual result:  Page 1 of 3
Expected:       Page 1 of 2

7.  Scroll down to second page

Statusbar shows

Actual result:    Page 3 of 3 (Page 1)
Expected:         Page 2 of 2 (Page 1)

Also produced in: 
Version: 7.0.0.0.alpha0+ (x64)
Build ID: dfd027342e6b4107ebd3369de96ef2be3883724d
Comment 1 Dieter 2020-02-06 18:25:25 UTC
Change view to book view and the second page is shown as blank page. We have a lot of simliar bug reports, but it's the intended behaviour (but documentation could be improved)

*** This bug has been marked as a duplicate of bug 128626 ***
Comment 2 sdc.blanco 2020-02-07 00:14:01 UTC
(In reply to Dieter from comment #1)
> Change view to book view and the second page is shown as blank page. 
> We have a lot of simliar bug reports, 
> but it's the intended behaviour (but documentation could be improved)
Thanks for the explanation Dieter (and links to related bugs). I tried (and obviously failed) to find similar bugs before filing this one.  After reading those bugs, I looked for documentation, but could not find any, though it was suggested in bug #126284, comment 8.  Have you found any?  

There was a change in the status bar between 6.3 and 7.0, but I still find it confusing. Seems strange to treat all "Insert Page Break, restart numbering" as though the intention was to print books.