Bug 130500 - Add Sukapura icon Theme to Core and Set It to Default for macOS
Summary: Add Sukapura icon Theme to Core and Set It to Default for macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.0.0
Keywords: needsUXEval
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2020-02-07 07:45 UTC by Rizal Muttaqin
Modified: 2020-02-26 08:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-02-07 07:45:18 UTC
As a supported platform, LibreOffice for macOS lacks dedicated icon theme that blends natively to the system. In the previous discussion here (https://bugs.documentfoundation.org/show_bug.cgi?id=42082) we could find many different suggestions about which icon theme should be set as default for macOS platform. From my point of view, using current available icon theme in the core is not the right choice. Breeze theme should be dedicated for KDE Plasma 5, while Sifr are intended to be the theme for accessibility and Colibre is the only Windows-y choice. 

So let me introduce a brand new icon theme: Sukapura, the name is taken after a kingdom of my hometown Tasikmalaya. Here some of Sukapura's fact

- Based on Colibre theme, so it is flat by design. While it is based on Colibre but the design is not merely the same. Other than the colors palette follow macOS standard system colors (https://developer.apple.com/design/human-interface-guidelines/macos/visual-design/color/) that will eventually give maximum blendity to the system, Sukapura use different geometrical shape such as arrow comparing to Colibre's.

- Has full SVG support, so likely it has big advantage for future need, like HIDPi support etc.

- As I write this bug report, Sukapura could be considered 99% finished. So it will not fallback to other theme. The last things that should be taken care is adding localization support for some of formatting toolbar (B,I,U, etc).

Everyone could test by installing it from my Github repo:

https://github.com/rizmut/libreoffice-style-sukapura

Look at the screenshot:

https://raw.githubusercontent.com/rizmut/libreoffice-style-sukapura/master/preview.png

Try it with extension:

https://github.com/rizmut/libreoffice-style-sukapura/blob/master/build/Sukapura-IconSet.oxt


For someone who concern about larger installation size, may be we should consider to remove Tango as it's not relevant now (GNOME 3 has join flat design trend finally) and no one interested to maintain it. But it just a choice of course.
Comment 1 Roman Kuznetsov 2020-02-07 07:58:48 UTC
Looks nice, I should check it on mac and comparise view between elementary/KJ and this new Sukapura icon Theme.

ps: Rizal, it's really cool! Thank you.
Comment 2 Pedro 2020-02-07 09:59:09 UTC
I support the implementation of this icon set 100%.
MacOS is the only DE/OS without a native icon set in LO and it deserves to be the same as the others.
With this we will have:
Colibre - Windows
Breeze - Plasma
Elementary - Gnome DE's
Sukapura - MacOS
Sifr - High contrast theme
Comment 3 V Stuart Foote 2020-02-07 13:45:17 UTC
+1, of course will need light and dark variants for macOS's light/dark & auto theme modes.
Comment 4 Kevin Suo 2020-02-08 06:51:47 UTC
Why it is still UNCONFIRMED even if many of you guys are supporting this FEATURE REQUEST.
Comment 5 Roman Kuznetsov 2020-02-08 07:02:30 UTC
(In reply to Kevin Suo from comment #4)
> Why it is still UNCONFIRMED even if many of you guys are supporting this
> FEATURE REQUEST.

Because it will duscuss on ESC anyway
Comment 6 Heiko Tietze 2020-02-21 10:13:04 UTC
No objection in the ESC 2020-Feb-20. Patch is here https://gerrit.libreoffice.org/c/core/+/89183
Comment 7 Commit Notification 2020-02-26 08:17:39 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a8c3addfce4df0fa8278d83764148d4aec40b36e

Resolves tdf#130500 - Sukapura icon theme

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Rizal Muttaqin 2020-02-26 08:52:34 UTC
(In reply to Rizal Muttaqin from comment #0)
 
> - As I write this bug report, Sukapura could be considered 99% finished. So
> it will not fallback to other theme. The last things that should be taken
> care is adding localization support for some of formatting toolbar (B,I,U,
> etc).

As I reply this and  the icon was submitted, now localization support has been finished also.