Bug 130516 - Can't set field properties when creating a new DB in Design View
Summary: Can't set field properties when creating a new DB in Design View
Status: RESOLVED DUPLICATE of bug 130623
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-07 20:42 UTC by Ken Gramm
Modified: 2020-02-12 16:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
New DB Table, no field properties (10.84 KB, image/png)
2020-02-07 20:44 UTC, Ken Gramm
Details
Field Properties are viewable when you edit table. (12.88 KB, image/png)
2020-02-07 20:45 UTC, Ken Gramm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Gramm 2020-02-07 20:42:01 UTC
Description:
When creating a new database table, you cannot set the field properties for your fields.  Instead of having the options displays at the bottom of the screen, I just get a blank gray area.

If I save the table, and then edit it, the field properties are displayed and can be edited.

This is a Firebird based database and I'm using openjdk 11.0.6 for java.

Steps to Reproduce:
1. Open Base
2. Create a new table in Design View.
3. Start creating a new field.

Actual Results:
Field properties are not displayed.

Expected Results:
Field properties to be displayed.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Although this machine is Fedora 31, I am not running the prepackaged version of LibreOffice.  This version was downloaded directly from the LibreOffice website.

Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 Ken Gramm 2020-02-07 20:44:54 UTC
Created attachment 157738 [details]
New DB Table, no field properties
Comment 2 Ken Gramm 2020-02-07 20:45:42 UTC
Created attachment 157739 [details]
Field Properties are viewable when you edit table.
Comment 3 Julien Nabet 2020-02-07 21:26:22 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 4 Xisco Faulí 2020-02-12 16:59:22 UTC
Thanks for reporting this issue.
This is a duplicate of bug 130623

*** This bug has been marked as a duplicate of bug 130623 ***