Download it now!
Bug 130631 - alt-letter menu accelerators are broken in non-latin keyboard layouts on linux
Summary: alt-letter menu accelerators are broken in non-latin keyboard layouts on linux
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators KDE
  Show dependency treegraph
 
Reported: 2020-02-13 07:53 UTC by lvm
Modified: 2020-10-20 04:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lvm 2020-02-13 07:53:15 UTC
Description:
Linux and LibreOffice with English UK UI (Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB), English US and Russian keyboard layouts are installed. In English layout Alt-letters act as menu accelerators but in Russian layout they generate plain Cyrillic characters. Both Writer and Calc are affected. 


Steps to Reproduce:
prerequisites: English and Russian keyboard layouts are installed

1. start writer 
2. switch to Russian keyboard layout
3. press Alt-F

Actual Results:
cyrillic letter А (the Cyrillic character located on F keyboard button in Russian layout) is typed into the document body

Expected Results:
File menu should've been opened


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 1 lvm 2020-04-21 10:59:40 UTC
Fixed in 6.4.3.2
Comment 2 lvm 2020-06-27 13:25:43 UTC
...but not completely. Only top-level menu accelerators work properly, second+ level menus are still broken, i.e:

1. start writer 
2. switch to Russian keyboard layout
3. press Alt-F - here file menu opens as expected
4. press Alt-O - nothing happens (file-_o-pen dialogue should've opened)

Reopening.

Version: 6.4.4.2
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 3 Roman Kuznetsov 2020-10-19 16:14:48 UTC
(In reply to lvm from comment #2)
> ...but not completely. Only top-level menu accelerators work properly,
> second+ level menus are still broken, i.e:
> 
> 1. start writer 
> 2. switch to Russian keyboard layout
> 3. press Alt-F - here file menu opens as expected
> 4. press Alt-O - nothing happens (file-_o-pen dialogue should've opened)
> 
> Reopening.
> 
> Version: 6.4.4.2
> Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
> CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
> Calc: threaded

Confirm in

Version: 7.1.0.0.alpha0+
Build ID: 83aa172697c11a9550c27a28f8e62b523ec7086d
CPU threads: 4; OS: Linux 5.5; UI render: default; VCL: kf5
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-10_21:26:34
Calc: threaded
Comment 4 Jan-Marek Glogowski 2020-10-19 17:21:06 UTC
(In reply to lvm from comment #2)
> ...but not completely. Only top-level menu accelerators work properly,
> second+ level menus are still broken, i.e:
> 
> 1. start writer 
> 2. switch to Russian keyboard layout
> 3. press Alt-F - here file menu opens as expected
> 4. press Alt-O - nothing happens (file-_o-pen dialogue should've opened)

I can reproduce this with all KDE apps, like kate, if I set the keyboard layout to "ru".
Same happens with the RichText editor example from Qt5 (Debian: qtbase5-examples): /usr/lib/x86_64-linux-gnu/qt5/examples/widgets/richtext/textedit/textedit
That should be a plain Qt program.

Please check, if this works for you with other KDE / Qt programs.
BTW: this setup also doesn't work with Gtk programs here, like Firefox.
And doesn't work correctly in WindowMaker with setxkbmap ru and the Qt example program.

From my POV there is nothing I can fix. Looks like a Qt bug.
Comment 5 lvm 2020-10-19 17:52:06 UTC
(In reply to Jan-Marek Glogowski from comment #4)

> From my POV there is nothing I can fix. Looks like a Qt bug.
Yes, looks like it is. Closing.
Comment 6 Roman Kuznetsov 2020-10-19 19:08:57 UTC
NOTOURBUG is a better status for this case