Bug 130633 - Writer hangs for a few seconds scrolling a particular document
Summary: Writer hangs for a few seconds scrolling a particular document
Status: RESOLVED DUPLICATE of bug 131185
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-02-13 09:25 UTC by Xisco Faulí
Modified: 2020-03-10 11:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
perf flamegraph (70.28 KB, application/x-bzip)
2020-02-13 19:45 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-13 09:25:49 UTC
Steps to reproduce:
1. Open attachment 157825 [details] from bug 130624
2. Scroll down and up

-> Writer hangs for a few seconds

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 718f540fb63af27c1336f89213444e9af753b8a9
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-02-13 09:27:42 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9fb7aaf570c03c8a26d763f1205fb8c890e8211a

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-04-13 16:58:49 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-04-16 02:52:02 +0200
commit	9fb7aaf570c03c8a26d763f1205fb8c890e8211a (patch)
tree	8f4466b24d9fcae2da5043479a57fabc662a2c43
parent	ba69036c8e889237da4bb312d7c5c94066abbfd3 (diff)
Make linked graphic register into LinkedManager again

Bisected with:

Adding Cc: to Tomaž Vajngerl
Comment 2 Xisco Faulí 2020-02-13 09:28:14 UTC
@Julien, would it be possible to have a perf chart for this issue ?
Comment 3 Julien Nabet 2020-02-13 09:34:05 UTC
No pb, I'll do it after my daytime job.
Comment 4 Julien Nabet 2020-02-13 19:45:58 UTC
Created attachment 157848 [details]
perf flamegraph

Here's a Flamegraph retrieved on pc Debian x86-64 with master sources updated today.
Comment 5 Xisco Faulí 2020-02-13 19:51:51 UTC
(In reply to Julien Nabet from comment #4)
> Created attachment 157848 [details]
> perf flamegraph
> 
> Here's a Flamegraph retrieved on pc Debian x86-64 with master sources
> updated today.

@Noel, I thought you might be interested in this flamegraph
Comment 6 Xisco Faulí 2020-03-10 11:20:50 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=30b23d77c894bdf6f7ae0d18d594ea267a80f662.
Closing as duplicate of bug 131185

*** This bug has been marked as a duplicate of bug 131185 ***