Download it now!
Bug 130660 - Don't hardcode paper sizes into LibreOffice Source code, store them in XML and provide GUI to add own sizes.
Summary: Don't hardcode paper sizes into LibreOffice Source code, store them in XML an...
Status: RESOLVED DUPLICATE of bug 106889
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-02-14 14:10 UTC by Wll|G]W$Ch'V<SeRrJ&`xN!NfY47?L
Modified: 2020-05-11 14:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wll|G]W$Ch'V<SeRrJ&`xN!NfY47?L 2020-02-14 14:10:17 UTC
Description:
I have tried to add a paper size (A0) to Writer. Only to figure out that they are hardcoded in C++.

I fell like it is mad do hardcode sizes into C++. Could you, please, store paper sizes in configs, and provide GUI to add and edit them?



Steps to Reproduce:
1. Go to page properties


Actual Results:
You are unable to add a paper size preset.

Expected Results:
You should be able to add a paper size presets via GUI.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.4.2
Build ID: 1:6.3.4-0ubuntu0.19.10.1
Comment 1 Wll|G]W$Ch'V<SeRrJ&`xN!NfY47?L 2020-02-14 14:15:25 UTC
BTW, feel free to delete this account.
Comment 2 ian 2020-02-14 23:12:59 UTC
Thank you for the suggestion. 

I have reduced the bug's severity to "enhancement."
Comment 3 Heiko Tietze 2020-05-11 14:35:36 UTC
Why do you need to edit a predefined variable? I mean you can enter any value at the page format and A0 is just a standard. Anyway, the request has been made before so this is a duplicate.

(In reply to Wll|G]W$Ch'V<SeRrJ&`xN!NfY47?L from comment #1)
> BTW, feel free to delete this account.

It was a pleasure to be of service to you.

*** This bug has been marked as a duplicate of bug 106889 ***