Bug 130679 - Draw: Convert to polygon doesn't work
Summary: Draw: Convert to polygon doesn't work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.3.6
Keywords: bibisected, bisected, regression
: 129970 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-15 10:16 UTC by Roman Kuznetsov
Modified: 2020-02-28 07:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-02-15 10:16:06 UTC
Description:
Draw: Convert to polygon doesn't work

Steps to Reproduce:
1. Open Draw
2. Insert an image
3. Right click on an image and select Convert->To polygon
4. It the dialog press Preview button => Nothing happens
5. Press OK button => Dialog will be close but the image will be the same without converting to vector

It doesn't work in 6.3 but it works as should in 6.2 => regression

Actual Results:
Convert to polygon doesn't work

Expected Results:
Convert to polygon works


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.3.3.2 (x64)
ID сборки: a64200df03143b798afd1ec74a12ab50359878ed
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 1 Julien Nabet 2020-02-15 10:53:43 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Let's increase a bit the importance since it's a regression.
Comment 2 Xisco Faulí 2020-02-15 10:59:48 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=407c45d54c189d5e9488e868e503f02955825b82

author	Noel Grandin <noel.grandin@collabora.co.uk>	2018-12-10 11:28:59 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2018-12-11 06:26:48 +0100
commit	1cd32bcf1b92bd53320717626601135623dadd55 (patch)
tree	5f33c3b070ac297bdba6bacb904d4ecd9644bef8
parent	34d5e910adba4094bba1303284f9552028d0b019 (diff)
loplugin:useuniqueptr in vcl

Bisected with: bibisect-linux64-6.3

Adding Cc: to Noel Grandin
Comment 3 Xisco Faulí 2020-02-17 15:13:11 UTC
*** Bug 129970 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2020-02-27 16:23:44 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dc5be8f6020dd812664af250d03d2a14b9e8a3cb

tdf#130679 Draw: Convert to polygon doesn't work

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-02-27 17:33:31 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: ab623953b92d82d615bd2af6a9369915fe6fb7a8
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!
Comment 6 Commit Notification 2020-02-27 18:34:21 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/2854c7293c45b5e5a86d7b390f8e198d09daec64

tdf#130679 Draw: Convert to polygon doesn't work

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-02-28 07:16:19 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/0cc4f712d07550fb42507a9a6a6e53bc333f29e6

tdf#130679 Draw: Convert to polygon doesn't work

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.