Bug 130702 - Font rendering problem in Libre Office
Summary: Font rendering problem in Libre Office
Status: RESOLVED DUPLICATE of bug 123456
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-16 09:25 UTC by florin.arjocu
Modified: 2020-02-17 16:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
libre office writer font rendering bug (1.58 MB, video/x-matroska)
2020-02-16 09:27 UTC, florin.arjocu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description florin.arjocu 2020-02-16 09:25:52 UTC
Description:
This is a very old bug, I have reported it some time ago and was replied that maybe I did something, but as I could see it active some versions later, I wanted to get back. I have not changed the settings of Libre Office (Write) and get this rendering bug. I have uploaded (https://youtu.be/ImIl4idb7So) a screen recording. I do think that I don't have a native Arial font installed, but the rendering problem should never occur either way. Selecting the badly rendered text moves the problem below. Scrolling so that text is out of the screen also changes the rendering problem.

Steps to Reproduce:
1. Open document
2. See the rendering problem
3. Select the badly rendered text or scroll so it gets out of the screen to move the rendering problem below. 

Actual Results:
Some lines are badly rendered.

Expected Results:
Good rendering.


Reproducible: Always


User Profile Reset: No



Additional Info:
Render properly
Comment 1 florin.arjocu 2020-02-16 09:27:10 UTC
Created attachment 157917 [details]
libre office writer font rendering bug

This is a very old bug, I have reported it some time ago and was replied that maybe I did something, but as I could see it active some versions later, I wanted to get back. I have not changed the settings of Libre Office (Write) and get this rendering bug. I have uploaded (https://youtu.be/ImIl4idb7So) a screen recording. I do think that I don't have a native Arial font installed, but the rendering problem should never occur either way. Selecting the badly rendered text moves the problem below. Scrolling so that text is out of the screen also changes the rendering problem.
Comment 2 Dieter 2020-02-16 20:05:23 UTC
(In reply to florin.arjocu from comment #1)
> This is a very old bug, I have reported it some time ago

Please give information about the number of the bug you've reported some time ago.

=> NEEDINFO

Basically, it's a good idea to remember a bug report, but you shouldn't do this with opening a new report.
Comment 3 florin.arjocu 2020-02-17 07:15:08 UTC
It is this report:
https://bugs.documentfoundation.org/show_bug.cgi?id=123456

I have experienced this for years, but every new release I hoped it would dissapear.
Comment 4 Dieter 2020-02-17 07:40:26 UTC
Florian, I will mark it as duplicate. There are a lot of open bugs and every developer is free to pick the bug he or she wants to pick. Looking at bug 12356 I saw, that there are not really steps to reproduce. Perhaps you can add them. It might also helpful to paste information, that the bug is still present in the newest version of LO.

*** This bug has been marked as a duplicate of bug 123456 ***
Comment 5 florin.arjocu 2020-02-17 16:22:09 UTC
As long as it gets some attention and in some point in the future, it will be fixed, that is perfectly ok. :)

I cannot offer steps as there are no other steps but to open the document. That is all, the bug is there. The thing is that not all the time, many times, but not always.