Download it now!
Bug 130762 - Degrees spinbutton is no longer wraps around (gen)
Summary: Degrees spinbutton is no longer wraps around (gen)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.3.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-02-18 20:03 UTC by Xisco Faulí
Modified: 2020-02-25 09:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-18 20:03:38 UTC
Steps to reproduce:
1. Open Calc
2. Format - Cells - Alignment
3. Put cursor in degrees' spinbutton
4. Press down key

-> Nothing happens. it should go to 355

Version: 7.0.0.0.alpha0+
Build ID: 28d844a589e52abfe62dc66b888e78665221ba28
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-02-18 20:05:19 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4ce5d39689fda418e8f2d7d9c1124190b2cbad7a

author	Caolán McNamara <caolanm@redhat.com>	2018-11-14 13:52:06 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-15 18:17:35 +0100
commit	4ce5d39689fda418e8f2d7d9c1124190b2cbad7a (patch)
tree	1e261f9e2b305fbdf56e3784c6589efbd683755b
parent	9e0a099fb66c303bec0489198ba7cfe770b28684 (diff)
bind SalInstanceSpinButton to FormattedField

Bisected with: bibisect-linux64-6.3

Adding Cc: to Caolán McNamara
Comment 2 Julien Nabet 2020-02-18 21:13:24 UTC
On pc Debian x86-64 with master sources updated today + gen rendering, I could reproduce this.
Just for the record but as expected since the title had indicated it, I don't reproduce this with gtk3.
Comment 3 Commit Notification 2020-02-19 14:03:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/20c08e47f7c156a4726194215b389f4d0b165904

Resolves: tdf#130762 honour "wrap" in FormattedField

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2020-02-19 14:04:39 UTC
fixed in master, backport to 6-4 in gerrit
Comment 5 Xisco Faulí 2020-02-24 11:31:58 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: f32a59a52e3ee2a0a8df9bb76bc1ff0ada7c7f1d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 6 Commit Notification 2020-02-24 11:34:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1c75d4df766098b51221ad20f9f569aff87d1b1b

Resolves: tdf#130762 honour "wrap" in FormattedField

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-02-24 15:41:32 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3c04c2ec10c3486c33dea6588d1eed9de09ee52d

tdf#130762: Add uitest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-02-25 09:41:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/1d50bf3839b37295dac7e3f91cdc21595285cecb

Resolves: tdf#130762 honour "wrap" in FormattedField

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.