Download it now!
Bug 130777 - UI Hide legend entry option for pie chart
Summary: UI Hide legend entry option for pie chart
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.0.0 target:7.1.0 target:7.0.0.1
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2020-02-19 14:37 UTC by NISZ LibreOffice Team
Modified: 2020-06-24 17:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Excel. (18.06 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-02-19 14:41 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem Calc (194.09 KB, image/png)
2020-02-19 14:41 UTC, NISZ LibreOffice Team
Details
Screenshot of the data point settings window (62.42 KB, image/png)
2020-02-19 22:46 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-02-19 14:37:39 UTC
Description:
There is no Hide legend entry option for the datapoint.

Steps to Reproduce:
    1. Open the xlsx file, which contains a simple pie chart with a hidden legend entry.
    2. Edit the pie chart, open theData Series dialog.
    3. There is no Hide legend entry option for the datapoint

Actual Results:
The is no Hide legend entry option for the datapoint.

Expected Results:
Be able to configure the Hide legend entry option, similarly to bar and other chart types.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 41177730421f9be9ad955766a5a19667d8003b11
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: hu-HU
Calc: threaded
Comment 1 NISZ LibreOffice Team 2020-02-19 14:41:00 UTC
Created attachment 158007 [details]
Example file from Excel.
Comment 2 NISZ LibreOffice Team 2020-02-19 14:41:28 UTC
Created attachment 158008 [details]
Screenshot of the problem Calc
Comment 3 Gabor Kelemen 2020-02-19 22:46:28 UTC
Created attachment 158015 [details]
Screenshot of the data point settings window

Unfortunately there seems to be no dialog tab for the Data Point dialog where this option would nicely fit. 
The Data Series -> Options tab does not appear for individual data points, and here only settings valid for all data points (except for Area settings...) can be set.
Comment 4 Xisco Faulí 2020-02-21 15:54:49 UTC
Changing it to 'enhancement'
Comment 5 Commit Notification 2020-03-03 12:31:44 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/381c9c6e5d179cf1d4dde9088fa5124fe2c36a99

tdf#130777 UI: add Hide legend entry option for pie chart

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-06-22 10:16:02 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/56b5099a57d3415c646ffcf98a1115ec0ca588a3

tdf#130777 tdf#51671 (related) Document "Hide legend entry" option
Comment 7 Commit Notification 2020-06-22 10:38:33 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/help/commit/a70efb219e762f5ccf5a1d36826859d9c726fbc9

tdf#130777 tdf#51671 (related) Document "Hide legend entry" option
Comment 8 BogdanB 2020-06-24 17:21:34 UTC
Verified. Ok

Version: 7.0.0.0.beta2+
Build ID: 77e4943cc6cf206a45901e5c87fabf0f783c8262
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-06-24_02:22:53
Calc: threaded