Download it now!
Bug 130799 - FILEOPEN DOCX Table cells missing vertical lines
Summary: FILEOPEN DOCX Table cells missing vertical lines
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Szabolcs Toth
URL:
Whiteboard: target:7.0.0 target:6.4.2
Keywords: bibisected, bisected, filter:docx, regression
: 130811 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2020-02-20 09:45 UTC by NISZ LibreOffice Team
Modified: 2020-02-24 11:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Word and Writer (104.49 KB, image/jpeg)
2020-02-20 09:46 UTC, NISZ LibreOffice Team
Details
Example file from Word (9.02 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-02-20 09:46 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-02-20 09:45:35 UTC
Description:
Table cells vertical lines in DOCX documents created with Microsoft Word missing when the document is opened in LibreOffice Writer 6.4.0.3.

Steps to Reproduce:
1. Open the attached DOCX file in LibreOffice Writer.
2. Open a copy in Microsoft Word.
3. Compare the original file opened in Writer and Word.
4. View the attached screenshot.
5. Notice, that table vertical lines are missing

Actual Results:
Table cells vertical lines are missing when the document is opened in LibreOffice Writer 6.4.0.3.

Expected Results:
Table cells should have vertical lines when the document is opened in LibreOffice Writer, like in Microsoft Word.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-GB
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-02-20 09:46:23 UTC
Created attachment 158028 [details]
Screenshot of the original document side by side in Word and Writer
Comment 2 NISZ LibreOffice Team 2020-02-20 09:46:44 UTC
Created attachment 158029 [details]
Example file from Word
Comment 3 Xisco Faulí 2020-02-20 13:44:04 UTC
*** Bug 130811 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2020-02-21 09:41:28 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/111db716c23f9f8450eda58c13dd2423770fd15e

tdf#130799 DOCX import: fix missing inside vertical borders

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-02-21 17:02:54 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/541f5b508e7d356803eac2bdce4278649ee76203

tdf#130799 DOCX import: fix missing inside vertical borders

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-02-24 11:22:11 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: f32a59a52e3ee2a0a8df9bb76bc1ff0ada7c7f1d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Szabolcs Toth, thanks for fixing this issue!