Download it now!
Bug 130809 - File dialogs in Mac OS are in German
Summary: File dialogs in Mac OS are in German
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Mac OS X (All)
: high major
Assignee: Stephan Bergmann
URL:
Whiteboard: target:7.0.0
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-02-20 13:15 UTC by Chris Shaw
Modified: 2020-03-11 13:51 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen grabs of File->Save As dialog, plus LO and system language dialogs (195.17 KB, image/png)
2020-02-20 13:40 UTC, Chris Shaw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Shaw 2020-02-20 13:15:30 UTC
Description:
Despite all my Language settings being on English (US) or English (UK), the file dialogs (open, save as etc) on Mac OS all come out in German

Steps to Reproduce:
1. Choose File->Open
2.
3.

Actual Results:
UI elements are in German - New folder button, Favourites, OK/Cancel etc

Expected Results:
UI elements should respect language settings


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+
Build ID: 0cb4f304abf6f8dd6b40eb800788d2fe80581813
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

MacOS Mojave
10.14.6 (18G2022)
Macbook Air 2018
Comment 1 Chris Shaw 2020-02-20 13:40:21 UTC
Created attachment 158044 [details]
Screen grabs of File->Save As dialog, plus LO and system language dialogs
Comment 2 eisa01 2020-02-20 19:37:46 UTC
Can confirm.

Raising importance as this would be very annoying in a release version

6.3.5.2 has English buttons, so this is a regression

Version: 7.0.0.0.alpha0+
Build ID: 0cb4f304abf6f8dd6b40eb800788d2fe80581813
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Stephan Bergmann 2020-02-27 15:54:58 UTC
sounds similar to bug 125693
Comment 4 Stephan Bergmann 2020-02-27 20:53:55 UTC
(In reply to Stephan Bergmann from comment #3)
> sounds similar to bug 125693

Yes, the issue is again that the empty directory LibreOfficeDev.app/Contents/Resources/en.lproj/ is missing, at least from <https://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@tb81-TDF/2020-02-27_03.15.21/LibreOfficeDev_7.0.0.0.alpha0_MacOS_x86-64.dmg> (as currently offered at <https://dev-builds.libreoffice.org/daily/master/current.html>).

The code from <https://git.libreoffice.org/core/+/47a774fbef8c224e4853de3fdd0230b9442bb716%5E%21> "tdf#125693: On macOS, create empty LibreOffice.app/Contents/Resources/en.lproj" (see bug 125693 comment 12) is still there.  It must be some new reason why the directory is missing from --with-package-format=dmg installation sets.
Comment 5 Stephan Bergmann 2020-02-28 07:48:27 UTC
@cloph: maybe you have an idea what could have changed when building installation sets (could reproduce this locally on current master with both --with-package-format=archive and --with-package-format=dmg; neither of the two resulting workdir/installation/LibreOffice/{archive,dmg}/install/en-US/LibreOffice_7.0.0.0.alpha0_MacOS_x86-64.* installation sets contains the empty LibreOffice.app/Contents/Resources/en.lproj/ directory)
Comment 6 Stephan Bergmann 2020-02-28 10:38:37 UTC
<https://gerrit.libreoffice.org/c/core/+/89694> " tdf#130809: Fix adding empty Contents/Resources/en.lproj into installation sets"
Comment 7 Commit Notification 2020-02-28 12:27:43 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/50b6f97730ecf5ed79b0ac05dea9b9b163108aae

tdf#130809: Fix adding empty Contents/Resources/en.lproj into installation sets

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-03-04 12:08:38 UTC
@Chris, @eisa, could you please verify the issue is fixed for you ?
Comment 9 Chris Shaw 2020-03-05 23:09:39 UTC
I downloaded the latest nightly build - 2020-02-28_05.23.33 - and it isn't fixed, but that's the same day Stephan committed the patch. I was waiting for a new build
Comment 10 Stephan Bergmann 2020-03-10 18:21:07 UTC
<https://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@tb81-TDF/2020-03-10_13.13.14/LibreOfficeDev_7.0.0.0.alpha0_MacOS_x86-64.dmg>, now available as "MacOSX-x86_64@tb81-TDF 2020-03-10 13:10:27" at <https://dev-builds.libreoffice.org/daily/master/current.html>,

> Version: 7.0.0.0.alpha0+
> Build ID: bd7f647b16ca2c5f9ef7d4b0945201c4f2ecebad
> CPU threads: 8; OS: Mac OS X 10.15.3; UI render: default; VCL: osx; 
> Locale: en-US (en_DE.UTF-8); UI-Language: en-US
> Calc: threaded

has an empty LibreOfficeDev.app/Contents/Resources/en.lproj/ and "File - Open..." opens the system file dialog with UI elements in English.
Comment 11 Chris Shaw 2020-03-11 13:51:03 UTC
Confirmed as FIXED in build

2020-03-11 05:13:31

Version: 7.0.0.0.alpha0+
Build ID: cba20762aba9abf17e94790e1bd99e1293050385
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Many thanks