Download it now!
Bug 130817 - FILEOPEN: Incorrect footnote symbol
Summary: FILEOPEN: Incorrect footnote symbol
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.2
Keywords: bibisected, bisected, regression
: 130824 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-20 17:36 UTC by Xisco Faulí
Modified: 2020-02-24 20:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.0 master (26.01 KB, image/png)
2020-02-20 17:36 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-20 17:36:46 UTC
Created attachment 158057 [details]
Comparison MSO 2010 and LibreOffice 7.0 master

Steps to reproduce:
1. Open attachment 133747 [details] from bug 108266

-> footnotes are roman numbers instead of $ symbol. See comparison image

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: bc994a4b01cf61444452bb377010c7c4cc377698
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-02-20 17:37:45 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b87af9775167002d36a3bc16cb308ea7895d7ea0

author	Jan-Marek Glogowski <jan-marek.glogowski@extern.cib.de>	2020-01-20 22:49:31 +0100
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2020-01-30 15:35:03 +0100
commit	b87af9775167002d36a3bc16cb308ea7895d7ea0 (patch)
tree	02507035fb6df79ea53cf5bdfeac9b0465c899f8
parent	7f56bbe3a09265a62792dc0624fdb44f8c176172 (diff)
tdf#129659 DOCX check global footnote context

Bisected with: bibisect-linux64-6.5

Adding Cc: to Jan-Marek Glogowski
Comment 2 Xisco Faulí 2020-02-22 10:28:48 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=38306ea92560c82b0d70bdc195267549a8bab830
For some reason, bugzilla didn't notify us
Comment 3 Xisco Faulí 2020-02-22 10:46:49 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: f0a50d230756fc0a60780d992b807f9eb82106c2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Jan-marek, thanks for fixing this issue!
Comment 4 Xisco Faulí 2020-02-22 11:16:43 UTC
*** Bug 130824 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2020-02-24 17:08:59 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/6901a41856a7710fd75f200ea127d55499d942b5

tdf#130817 RTF doesn't set custom footnote state

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-02-24 20:04:15 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/74a25e38056a608f0a013b43689a3c03ee710837

tdf#130817: Add unittest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.