Download it now!
Bug 130832 - EDITING Calc freezes on Ctrl+A, Delete
Summary: EDITING Calc freezes on Ctrl+A, Delete
Status: RESOLVED DUPLICATE of bug 125792
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-21 09:39 UTC by stdedos
Modified: 2020-05-10 14:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Clean (57.23 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-02-21 20:27 UTC, stdedos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stdedos 2020-02-21 09:39:41 UTC
Description:
I have a workbook, with 2~25 worksheets, that I only "work" around the ['A1':'I41'] region, and is saved as `xlsx`.

As I was trying to sanitize a document to upload here, I thought that "Ctrl+A, Delete" was the quickest way to do it.

I am betting that Calc will be frozen for 5min+the-bug-report-creating-time, and then some

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
libreoffice-6.4.0.3-snap1
Comment 1 stdedos 2020-02-21 10:12:03 UTC
A1:K42* is the area
Comment 2 stdedos 2020-02-21 13:41:53 UTC
May or may not be related to "Tracking Changes" being "magically" enabled
Comment 3 Xisco Faulí 2020-02-21 15:29:54 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 4 stdedos 2020-02-21 20:27:46 UTC
Created attachment 158093 [details]
Clean
Comment 5 stdedos 2020-02-21 20:32:31 UTC
(In reply to Xisco Faulí from comment #3)
> Thank you for reporting the bug. Please attach a sample document, as this
> makes it easier for us to verify the bug. 

You may have noticed that I said:

> ... I was trying to sanitize a document to upload here, I thought that "Ctrl+A, Delete" was the quickest way to do it.

I was trying *to clean* the file for upload. Therefore, I *cannot* upload "the file".

So, take a clean file, fill (or don't) some data in A1:K42 for all sheets, activate (or don't) "Track Changes", and maybe you will replicate it.
Comment 6 Buovjaga 2020-05-10 14:33:21 UTC

*** This bug has been marked as a duplicate of bug 125792 ***