Download it now!
Bug 131046 - Writer table: "Number Format..." removed from context menu
Summary: Writer table: "Number Format..." removed from context menu
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 132452 (view as bug list)
Depends on:
Blocks: Context-Menu Writer-Tables
  Show dependency treegraph
 
Reported: 2020-03-01 08:08 UTC by Oliver Brinzing
Modified: 2020-04-28 03:52 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Brinzing 2020-03-01 08:08:40 UTC
It seems the entry "Number Format..." has been removed from the table context menu.

steps to reproduce:
- new writer document
- insert a writer table
- cell A1 
- context menu
- missing entry "Number Format..."

was available in LO 6.1.6.3
Comment 1 Thomas Lendo 2020-03-01 09:58:00 UTC
I assume this was changed among many other context menu items by Andreas. Maybe I'm wrong.

CCing him.
Comment 2 andreas_k 2020-03-03 15:44:57 UTC
Number Format... is an very specific option and as this command is available in the table toolbar I think it's ok to have it not available in the context menu.

Since you can customize context menu, I'm not sure, if table context menu should get "Number Format..." by default.
Comment 3 Dieter 2020-03-03 15:59:43 UTC
(In reply to andreas_k from comment #2)
> Number Format... is an very specific option and as this command is available
> in the table toolbar I think it's ok to have it not available in the context
> menu.
> 
> Since you can customize context menu, I'm not sure, if table context menu
> should get "Number Format..." by default.

I agree
Comment 4 Heiko Tietze 2020-03-05 14:15:12 UTC
Number format in the context menu of tables in Writer shouldn't be too important. So better we keep the menu concise => WFM. Opposite opinion?
Comment 5 V Stuart Foote 2020-03-05 15:38:21 UTC
Not a Bug and by design while consolidating the dialogs. 

Numbers entered as table cell text are direct formatted as characters individually, or for the paragraph.

While a table cell assigned Numbering or Bullets is already exposed for direct formatting via the context menu 'Bullets and Numbering' -> 'Bullets and Numbering...' pop-up dialog (.uno:OutlineBullet) where the 'Customize' tab controls the direct formatting.

Likewise, for style based authoring the 'Table contents' paragraph style provides the 'Outline & Numbering' panel for droplist selection and 'Edit style' of the 'Numbering style' applied.

It has been trivial to customize the Context menu and assign commands like the .uno:OutlineBullet dialog to an additional location if desired, but it is already there.

-1, => NAB, and WF
Comment 6 Oliver Brinzing 2020-04-28 03:52:01 UTC
*** Bug 132452 has been marked as a duplicate of this bug. ***