Download it now!
Bug 131047 - UI: Find All search result frame cannot resized (gen)
Summary: UI: Find All search result frame cannot resized (gen)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:7.1.0 target:7.0.1 target:6.4.7
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2020-03-01 09:30 UTC by Thomas Lendo
Modified: 2021-01-11 21:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Find All Search Results dialog window when vertically streched (47.52 KB, image/jpeg)
2020-07-28 06:43 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2020-03-01 09:30:48 UTC
Actually the Find All search result frame in this dialog window cannot be resized e.g. by mouse. Only the Find All dialog window can be resized but then the result frame in it doesn't change.

This looks ugly and is unhandy.

Expected result:
The Find All search result frame in the dialog windows is resizing in exakt the same way as the dialog window itself will be resized by the user.

I haven't any idea how LibreOffice handles such user resizing elsewhere. Should such change be forgotten after closing the window or by session or file or user profile?
Comment 1 Heiko Tietze 2020-03-02 12:29:57 UTC
What exactly are you talking about? Calc and the summary? Resizes for me but only vertically. Why is this an enhancement?

Version: 6.3.5.2 Linux 5.5; VCL: kde5; Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Comment 2 Thomas Lendo 2020-07-28 06:43:37 UTC
Created attachment 163666 [details]
Screenshot of Find All Search Results dialog window when vertically streched
Comment 3 Thomas Lendo 2020-07-28 06:50:28 UTC
I will try with another wording:

When searching for something and clicking at 'Find All' in the search toolbar, then the Search Results dialog window opens.

This window can be resized vertically and horizontally. But the search results frame inside of the dialog window only resizes horizontally.

Expected result:
The search results frame inside of the dialog window should also resize vertically. See attached screenshot.

Reasons for this enhancement:

* The behavior when resizing a dialog window should bring the same UI result for all directions. Why is the window behave differently vertically than horizontally?

* When there are many search results, the user can see much more of it when the results frame also gets bigger. Now only 15 items are visible, whether the dialog window will resized or not.
Comment 4 Heiko Tietze 2020-07-28 07:02:11 UTC
Works for me without problems, respective flag is set in the ui file.
sc/uiconfig/scalc/ui/searchresults.ui

Might be a Windows issue.
Comment 5 Heiko Tietze 2020-07-28 07:02:55 UTC
(In reply to Heiko Tietze from comment #4)
> Works for me

Version: 7.1.0.0.alpha0+
Build ID: 14e87a4b15d31a34e6053f6194688f3aa23af991
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Thomas Lendo 2020-07-28 08:09:17 UTC
Works not with
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: de-AT (de_AT); UI: en-US
Calc: threaded

with the daily master built from yesterday.

(It looks like that the build version is not copied in the About window.)
Comment 7 S.Zosgornik 2020-07-28 08:23:04 UTC
I can confirm that it's works on Linux in version 6.3
but it doesn't works on Windows in 6.4
Comment 8 Heiko Tietze 2020-07-28 08:46:04 UTC Comment hidden (off-topic)
Comment 9 Xisco Faulí 2020-08-10 16:50:58 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 6ad2f463784a24c566477cdd60ae729651bb8564
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 10 Xisco Faulí 2020-08-10 16:52:24 UTC
Not reproducible with gtk3

Version: 7.1.0.0.alpha0+
Build ID: 6ad2f463784a24c566477cdd60ae729651bb8564
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 11 Xisco Faulí 2020-08-10 22:24:48 UTC
Patch in https://gerrit.libreoffice.org/c/core/+/100453
Comment 12 Commit Notification 2020-08-11 08:07:56 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7841adec312b4993156cdbd9702223e8f1f34132

tdf#131047: expand search results frame

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-08-11 08:37:40 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bc652f68d988a6fd0e2feb51b0e3ccfee31e6693

tdf#131047: expand search results frame

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-09-21 21:49:56 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/38e0b926203262d90e4ec9b33860416b4074ba63

tdf#131047: expand search results frame

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 ffs 2021-01-11 21:17:02 UTC
Thanks for the fix - I was just going to report this irritating bug in 6.4.6.2!