Download it now!
Bug 131079 - LibreOffice Crashes After Attempting to Highlight a Hyperlink
Summary: LibreOffice Crashes After Attempting to Highlight a Hyperlink
Status: RESOLVED DUPLICATE of bug 129809
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2020-03-02 19:51 UTC by jbhughes54enwiler
Modified: 2020-03-02 22:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jbhughes54enwiler 2020-03-02 19:51:30 UTC
Description:
LibreOffice Writer (And possibly other applications, I haven't checked) will crash as soon as I let go of the mouse button if I try to click and drag over a hyperlink.  It will immediately go into the document recovery dialog (Thankfully I didn't lose anything) and will work normally after the application reopens.  The crash is consistent and happens every time I perform the action of clicking and dragging.  

Steps to Reproduce:
1.Create a hyperlink in a document
2.Attempt to click and drag over it
3.Let go of the mouse button

Actual Results:
LibreOffice Writer instantly crashes and goes into document-recovery mode

Expected Results:
Highlighted the selected text


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Clicking and dragging highlights nothing, the cursor will turn into a broken highlight cursor.
Comment 1 Ming Hua 2020-03-02 20:15:22 UTC
Thanks for reporting this bug.  However, the most recent version of the 6.3 series is the recently released 6.3.5, with quite a few bugs fixed with respect to hyperlinks.

Would you please try installing 6.3.5 and test if this bug still exists?
Comment 2 jbhughes54enwiler 2020-03-02 20:35:02 UTC
(In reply to Ming Hua from comment #1)
> Thanks for reporting this bug.  However, the most recent version of the 6.3
> series is the recently released 6.3.5, with quite a few bugs fixed with
> respect to hyperlinks.
> 
> Would you please try installing 6.3.5 and test if this bug still exists?

I updated LibreOffice to 6.4.1.2 and the bug is still there.  However, I noticed that the crash only happens if I click and drag on top of the hyperlink.  It will highlight the link normally if I click and drag from outside the text of the hyperlink.
Comment 3 Dieter 2020-03-02 20:46:26 UTC
I can't confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 41177730421f9be9ad955766a5a19667d8003b11
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Do you recieve a crash report (please enable option in Tools => Option => LibreOffice => General)?
Comment 4 Ming Hua 2020-03-02 20:53:23 UTC
(In reply to jbhughes54enwiler from comment #2)
> I updated LibreOffice to 6.4.1.2 and the bug is still there.  However, I
> noticed that the crash only happens if I click and drag on top of the
> hyperlink.
Thanks for testing.  This specific crash sounds like bug 129809 (see its duplicate bug 129926).  Can you test with 6.4.2 RC1 (6.4.2.1) again which should have the fix?
Comment 5 jbhughes54enwiler 2020-03-02 22:20:15 UTC
(In reply to Ming Hua from comment #4)
> (In reply to jbhughes54enwiler from comment #2)
> > I updated LibreOffice to 6.4.1.2 and the bug is still there.  However, I
> > noticed that the crash only happens if I click and drag on top of the
> > hyperlink.
> Thanks for testing.  This specific crash sounds like bug 129809 (see its
> duplicate bug 129926).  Can you test with 6.4.2 RC1 (6.4.2.1) again which
> should have the fix?

I upgraded to 6.4.2.1 and that fixed the issue.  Thank you.
Comment 6 Ming Hua 2020-03-02 22:37:44 UTC
(In reply to jbhughes54enwiler from comment #5)
> (In reply to Ming Hua from comment #4)
> > (In reply to jbhughes54enwiler from comment #2)
> > > I updated LibreOffice to 6.4.1.2 and the bug is still there.  However, I
> > > noticed that the crash only happens if I click and drag on top of the
> > > hyperlink.
> > Thanks for testing.  This specific crash sounds like bug 129809 (see its
> > duplicate bug 129926).  Can you test with 6.4.2 RC1 (6.4.2.1) again which
> > should have the fix?
> 
> I upgraded to 6.4.2.1 and that fixed the issue.  Thank you.
Great.  Let's mark this one as a DUPLICATE then.

*** This bug has been marked as a duplicate of bug 129809 ***