Bug 131097 - Embedding fonts while saving a Writer document has no effect when opening it on a different PC
Summary: Embedding fonts while saving a Writer document has no effect when opening it ...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Embedded
  Show dependency treegraph
 
Reported: 2020-03-03 15:33 UTC by [REDACTED]
Modified: 2020-10-08 04:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description [REDACTED] 2020-03-03 15:33:47 UTC
Description:
The use of font embedding options on the Document Properties panel while saving a Writer document has no effect on the same document when it is opened on another PC which originally lacks the embedded font. The text displayed shows Arial font but not the embedded one.

System tested: Windows 10 Pro 64-bit v1909
Font tested: Linux Libertine OTF v5.3.0

Steps to Reproduce:
1. Work on a Writer document using Linux Libertine O font v5.3.0 font.
2. Save the document selecting "Embed fonts in the document".
3. Open it on a different PC which lacks the aforementioned font installed.
4. Ad editing the document, the texts shows as Arial even if the Font Selector shows the correct font (Linux Libertine O).
5. Exporting to PDF doesn't embed the font neither on the PDF file.

Actual Results:
What happens is I'm not able to continue working on my document while using another PC.

Expected Results:
The document should be completely editable allowing me to write text using the embedded font (Linux Libertine O) even when the system has no this font installed.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: es
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes

-----

[spanish]

Versión: 6.4.0.3 (x86)
Id. de compilación: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Subprocs. CPU: 4; SO: Windows 10.0 Build 18363; Repres. IU: GL; VCL: win; 
Configuración regional: es-AR (es_PE); Idioma de IU: es-ES
Calc: threaded
Comment 1 Dieter 2020-03-03 17:07:22 UTC
I'm not sure, if this is possible, so perhaps NOTABUG or an enhancement request. It might be useful to add an information to LO Help

https://help.libreoffice.org/7.0/en-GB/text/shared/01/prop_font_embed.html?System=WIN&DbPAR=WRITER&HID=sfx/ui/documentfontspage/DocumentFontsPage#bm_id3154926
Comment 2 Timur 2020-03-10 17:32:02 UTC
there are a few existing bugs, so this may be a duplicate,easy to search "embedded".
Comment 3 QA Administrators 2020-09-07 03:53:00 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2020-10-08 04:08:27 UTC
Dear Star Man,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp