Bug 131104 - Pasted text is reformated
Summary: Pasted text is reformated
Status: RESOLVED DUPLICATE of bug 105352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2020-03-03 20:08 UTC by Randy
Modified: 2020-03-08 18:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image illustrating formatting bug (19.48 KB, image/png)
2020-03-03 20:20 UTC, Randy
Details
Document sample of the bug (11.22 KB, application/vnd.oasis.opendocument.text)
2020-03-04 19:32 UTC, Randy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Randy 2020-03-03 20:08:26 UTC
Description:
Whenever I copy text and then paste it somewhere else in the document some or all of the text is reformatted.  For example, an unbolded line of text becomes bolded, or a line of text previously in arial font changes to Times New Roman. This is something that has happened consistently through all the different updates/versions I have used.

Steps to Reproduce:
1.Select text and copy
2.Select new point in document
3.Paste

Actual Results:
Text formatted in one style is reformatted with different attributes including font type and bolding and italics.

Expected Results:
Text formatting should remain the same as what was copied.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: CL
Comment 1 Randy 2020-03-03 20:20:04 UTC
Created attachment 158355 [details]
Image illustrating formatting bug
Comment 2 Dieter 2020-03-04 06:53:45 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.

I'm also not sure about your way you paste the text. I don't remember the keyboard shortcut, because I always use toolbar (you can select "unformated text" in the submenu of paste icon). Does this information solve your problem?
Comment 3 Randy 2020-03-04 16:26:45 UTC
I installed the latest version and tested.  It still reformats text.  For example, the text I was copying was arial(no bold or italic).  The space directly next to or below the area that I inserted the cursor to paste was bolded and italicized.  When I pasted the text, it reformatted the last line of text with bold and italics.  I tried pasting with the options but that didn't help either.
Comment 4 Dieter 2020-03-04 18:51:30 UTC
Randy, please attach a sample document, as this makes it easier for us to verify the bug. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.

(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 5 Randy 2020-03-04 19:32:57 UTC
Created attachment 158393 [details]
Document sample of the bug

I have attached a sample document as you requested.
Comment 6 Dieter 2020-03-04 20:01:35 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

and also with LO 5.4.7.2
Comment 7 Randy 2020-03-05 14:04:58 UTC
(In reply to Dieter from comment #6)
> I confirm it with
> 
> Version: 7.0.0.0.alpha0+ (x64)
> Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
> CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
> Locale: de-DE (de_DE); UI-Language: en-GB
> Calc: threaded
> 
> and also with LO 5.4.7.2

Do you need any further action from me?
Comment 8 Dieter 2020-03-05 17:21:46 UTC
(In reply to Randy from comment #7)
> Do you need any further action from me?

No. We have to wait, that a developer takes a look at it. But that could take some time, because we have a lot of open bugs.
Comment 9 Timur 2020-03-08 18:50:25 UTC
Rule of thumb is search before reporting and confirming. 
Looks like a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=105352

*** This bug has been marked as a duplicate of bug 105352 ***