Bug 131115 - FILEOPEN: Incorrect format of single data label
Summary: FILEOPEN: Incorrect format of single data label
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 132495 (view as bug list)
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2020-03-04 09:21 UTC by Xisco Faulí
Modified: 2020-05-04 09:09 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (13.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-03-04 09:21 UTC, Xisco Faulí
Details
6.4 (good) vs 7.0 master (bad) (35.46 KB, image/png)
2020-03-04 09:23 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-03-04 09:21:48 UTC
Created attachment 158371 [details]
sample file

Steps to reproduce:
1. Open attached document

-> Label 3 uses scientific format, thus it should be 3.00E+00, instead it's 3. See screenshot. Found while verifying bug 130986

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: c57d6d39c80844c9d4c6bfed85cc151e52a67b34
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-03-04 09:23:17 UTC
Created attachment 158372 [details]
6.4 (good) vs 7.0 master (bad)
Comment 2 Xisco Faulí 2020-03-04 09:25:42 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e57d90cd4e51a1353eafc87bb29cfe6076704a7c

author	Balazs Varga <balazs.varga991@gmail.com>	2019-12-10 12:53:08 +0100
committer	László Németh <nemeth@numbertext.org>	2019-12-16 08:58:25 +0100
commit e57d90cd4e51a1353eafc87bb29cfe6076704a7c (patch)
tree bdadf54a91203dcd32bd02a30d2187160c278d79
parent c5f593d68b7f6d8a2f2adc75d5bcb795822efeac (diff)
tdf#129173 tdf#129175 Fix number format of data labels

Bisected with: bibisect-linux64-6.5

Adding Cc: to Balazs Varga
Comment 3 Balázs Varga 2020-04-17 11:07:28 UTC
Probably fixed by:

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/434d92a51409b0847ee7d313b50fc547b7615bff

tdf#131979 Chart ODF import-export of Link to source format

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-04-21 16:06:05 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 850b8de31c5be5127eac16a4f5cc18c26a582e53
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I do confirm the issue is fixed by https://git.libreoffice.org/core/commit/434d92a51409b0847ee7d313b50fc547b7615bff

@Balázs Varga, thanks for fixing this issue!!
Comment 5 Xisco Faulí 2020-05-04 09:09:39 UTC
*** Bug 132495 has been marked as a duplicate of this bug. ***