Download it now!
Bug 131175 - FILEOPEN DOCX: chart labels black instead of white in grey rectangle
Summary: FILEOPEN DOCX: chart labels black instead of white in grey rectangle
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: low minor
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.0.0 target:7.1.0 target:7.0.1
Keywords: filter:docx
Depends on:
Blocks: OOXML-Chart 114170
  Show dependency treegraph
 
Reported: 2020-03-06 00:46 UTC by Gerald Pfeifer
Modified: 2020-09-07 09:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOCX document (22.47 KB, application/vnd.ms-word)
2020-03-06 00:46 UTC, Gerald Pfeifer
Details
How it should look like (Office 365) (53.19 KB, image/png)
2020-03-06 00:47 UTC, Gerald Pfeifer
Details
This is how it looks in LO (37.93 KB, image/png)
2020-03-06 00:48 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-03-06 00:46:28 UTC
Created attachment 158431 [details]
Sample DOCX document

The chart in this document shows labels as white text in a grey rectangle
in Office 365, but black (without a rectangle) in LibreOffice.
Comment 1 Gerald Pfeifer 2020-03-06 00:47:28 UTC
Created attachment 158432 [details]
How it should look like (Office 365)
Comment 2 Gerald Pfeifer 2020-03-06 00:48:10 UTC
Created attachment 158433 [details]
This is how it looks in LO
Comment 3 Timur 2020-03-06 09:57:43 UTC
This is a pattern fill of label. Also in MSO: solid fill, gradient fill, picture or texture fill, automatic. 
Reproduced in 7.0+, but looks like a duplicate. If not resolved there, we can reopen.
Rule of thumb is search before reporting.

*** This bug has been marked as a duplicate of bug 123206 ***
Comment 4 Gerald Pfeifer 2020-03-06 19:23:13 UTC
(In reply to Timur from comment #3)
> Reproduced in 7.0+, but looks like a duplicate. If not resolved there, we
> can reopen.

I'll keep an eye on this.

> Rule of thumb is search before reporting.

Yes, and I always do. Searching just does not necessarily imply finding.
Comment 5 Gabor Kelemen 2020-04-28 06:06:58 UTC
More like bug #114170 - the basic problem is that LO does not support the usual Area fill options for chart labels at all.

*** This bug has been marked as a duplicate of bug 114170 ***
Comment 6 Commit Notification 2020-05-04 19:06:03 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/603df08a1e0211099ce2cf258cfe64a74ed6ded9

tdf#131175 Import data label solid fill and color.

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Gerald Pfeifer 2020-05-04 19:37:02 UTC
(In reply to Gabor Kelemen from comment #5)
> More like bug #114170 - the basic problem is that LO does not support the
> usual Area fill options for chart labels at all.
> 
> *** This bug has been marked as a duplicate of bug 114170 ***

Not so much a duplicate of bug #114170 as one of many, many aspects of
that bug which could be considered a master bug.

Making this one a blocking bug of bug #114170 and marking it as FIXED.
One puzzle piece down, many more to go.
Comment 8 Timur 2020-05-08 13:38:27 UTC
No change. Gerald, I guess you didn't check this.
This is minor issue, because labels are visible. 
But if bug was to be the same as MSO, it's not.
Comment 9 Gerald Pfeifer 2020-05-20 12:55:29 UTC
(In reply to Timur from comment #8)
> No change. Gerald, I guess you didn't check this.
> This is minor issue, because labels are visible. 
> But if bug was to be the same as MSO, it's not.

Thank you, Timur!  Indeed you are right - whatever I though I had seen,
I've now retested twice over the last week (with different snapshots of
LO 7.0) and the issue is not resolved.
Comment 10 Commit Notification 2020-06-30 12:23:17 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6f752061d5153da50d6f536d506358c8f512a397

Related: tdf#131175 OOXML chart: import data label fill pattern

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-07-01 08:37:47 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e18bc316efbd815b047f4e19ebd033e7a842d10d

Related: tdf#131175 OOXML chart: insert hatch definition into the right table

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-07-15 08:54:19 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8a43bfeffab9009c9f373e883fef87af1a7b3843

tdf#131175 oox chart import: fix char color of <dLbl>, inherited from <dLbls>

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Miklos Vajna 2020-07-15 09:03:33 UTC
I think this is now fixed on master.
Comment 14 Gerald Pfeifer 2020-07-17 05:02:37 UTC
(In reply to Miklos Vajna from comment #13)
> I think this is now fixed on master.

Yes, I just verified. Thank you. Quite nice an achievement!

Do you agree that the missing shadow effect and showing solid color
instead of patterns or two issues worth filing separately? (I can take
care, just want to hear your expert opinion first.)
Comment 15 Miklos Vajna 2020-07-17 07:06:23 UTC
> Do you agree that the missing shadow effect and showing solid color
> instead of patterns or two issues worth filing separately? (I can take
> care, just want to hear your expert opinion first.)

Yes. The background color is actually a hatch/pattern already, but it could be improved to match the Word one more closely.

And right, the shadow is just missing.
Comment 16 Xisco Faulí 2020-07-20 09:36:40 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 17 Xisco Faulí 2020-07-20 09:39:17 UTC
The issue is reproducible in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.19; Render: default; 

Locale: en-US (en_US.UTF-8)
Comment 18 Commit Notification 2020-07-20 13:00:46 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/63726cb536e0d3d3c2a5199f6d19f354aef8030b

Related: tdf#131175 OOXML chart: import data label fill pattern

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-07-22 10:15:18 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/9f1d98a6a8a0e61ee4e021ac35d588e4bb025407

Related: tdf#131175 OOXML chart: insert hatch definition into the right table

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-07-22 10:15:29 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/b894890cfdddc7dd38f483c9a9b2592a24dd1697

tdf#131175 oox chart import: fix char color of <dLbl>, inherited from <dLbls>

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.