Download it now!
Bug 131179 - Android Viewer crashes trying to open document containing comments
Summary: Android Viewer crashes trying to open document containing comments
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.0.0
Keywords:
: 119762 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-06 09:34 UTC by Michael Weghorn
Modified: 2020-03-09 15:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document containing a comment (8.75 KB, application/vnd.oasis.opendocument.text)
2020-03-06 09:34 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2020-03-06 09:34:40 UTC
Created attachment 158436 [details]
Sample document containing a comment

When trying to open an ODT doc containing comments, LibreOffice Android Viewer crashes.

Steps to reproduce: open attached document "sample_with_comment.odt"

Result: Crash

Using Android Viewer built from current master, as of commit cedc8a942e451a63dd1e7dae7f25642c0fcb4be8
Comment 1 Michael Weghorn 2020-03-06 09:35:26 UTC
I've analysed the issue and will provide a fix myself, this ticket is mainly for documentation purposes.
Comment 2 Commit Notification 2020-03-06 15:48:00 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9989f7870cfb82722cf2fd6b9cfdf7aea77c0011

tdf#131179 android: Support docs containing comments

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Weghorn 2020-03-09 15:24:32 UTC
*** Bug 119762 has been marked as a duplicate of this bug. ***