Download it now!
Bug 131221 - Draw : pullwown menu for Line Width (line thickness) is empty
Summary: Draw : pullwown menu for Line Width (line thickness) is empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-08 09:53 UTC by Olaf
Modified: 2020-03-31 11:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf 2020-03-08 09:53:13 UTC
Description:
Draw  (Win 10): Pullwown Menu for Line Width (line thickness) is empty. 
This menue is on the right hand side of the drawing. On the first click onto thie line witdth menu, thie menu is always emtpty. If you click it again, then you see and can select a new line width (line thickness). In Version 6.2.5 this bug was not present

Actual Results:
Click on the pulldown Menue for line width thickness in the right hand side menue

Expected Results:
Clicking the pulldown menue must show the severals selectabel lind widths


Reproducible: Always


User Profile Reset: No



Additional Info:
Pullwon menue is empty. Clicking it a second time, pulldown menue is correct
Comment 1 Julien Nabet 2020-03-08 12:27:02 UTC
Which LO version do you use?
Last stable one is 6.3.5
Comment 2 Olaf 2020-03-08 12:50:46 UTC
(In reply to Julien Nabet from comment #1)
> Which LO version do you use?
> Last stable one is 6.3.5

My current LO Version is 6.3.5.2.
For test purposes I deinstalled current LO and reinstalled 6.2.5 : the reported bug ist not present at this older version 6.2.5.
I also tested 6.4.1: the same bug appears.
Thanks for replying and the very good Draw, I love it.
B. reg
Olaf Biese
Comment 3 Durgapriyanka 2020-03-10 14:59:38 UTC
Thank you for reporting the bug. Unfortunately I couldn't reproduce this in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Xisco Faulí 2020-03-19 11:59:01 UTC
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 5 Olaf 2020-03-28 10:55:13 UTC
(In reply to Xisco Faulí from comment #4)
> Could you please paste the info from Help - about LibreOffice ?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' once the information has been provided

Hi, here ist the about info, thanks a lot:   Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 6 Julien Nabet 2020-03-28 10:59:33 UTC
I noticed OpenGL in your last comment, could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28OpenGL.29 ?
Comment 7 Olaf 2020-03-29 07:03:57 UTC
(In reply to Julien Nabet from comment #6)
> I noticed OpenGL in your last comment, could you give a try at
> https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.
> 28OpenGL.29 ?

Hi, disabling OpenGL helped, the problem seems to be eliminated !

Activating OpenGL again, the bug is present again.

Thanks a lot for you help!

Question: 
Are there disadvanteges if OpenGL is disabled (e.g. a loss of functionality ?
Is the proper use of Metafile-Objects (stemming from converted Draw-Objects) still possible without OpenGL ?

Reason for my Question: 
one reason for using 6.3.5.2 instead of using  the former 6.2.5 is that there were problems with those metafile-objects.

Thanks a lot !
Olaf
Comment 8 Olaf 2020-03-29 07:36:32 UTC
Here ist the content of   "opengl_device.log"

DriverVersion: 25.20.100.6471
DriverDate: 12-28-2018
DeviceID: PCI\VEN_8086&DEV_5917&SUBSYS_00251414&REV_07
AdapterVendorID: 0x8086
AdapterDeviceID: 0x5917
AdapterSubsysID: 0x00251414
DeviceKey: System\CurrentControlSet\Control\Video\{7F4D05F7-040B-11EA-A2E2-9DC1B38CC606}\0000
DeviceString: Intel(R) UHD Graphics 620

Thanks
Comment 9 Olaf 2020-03-29 07:40:17 UTC
No newer driver is available according to Systemcontrol / Graphics / Driver / DriverUpdate. The computer is an "MS Surface Laptop 2"
Comment 10 Julien Nabet 2020-03-29 08:33:37 UTC
(In reply to Olaf from comment #7)
> ...
> Question: 
> Are there disadvanteges if OpenGL is disabled (e.g. a loss of functionality ?
> Is the proper use of Metafile-Objects (stemming from converted Draw-Objects)
> still possible without OpenGL ?
> ...
I'm not an expert but I think OpenGL is just to accelerate LO by using graphic card so you won't lose any feature.

I submitted a patch to blacklist OpenGL for this specific device, see https://gerrit.libreoffice.org/c/core/+/91321
Comment 11 Commit Notification 2020-03-29 12:22:15 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d4c9e2130f6f065b4a97fc98cf1029593e725e65

tdf#131221: blacklist Intel on Win10 deviceid 0x5917

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2020-03-29 12:29:49 UTC
I don't think it worths it to backport the patch on 6.4 branch since we just need to disable openGL.
Comment 13 Xisco Faulí 2020-03-30 10:28:36 UTC
(In reply to Julien Nabet from comment #12)
> I don't think it worths it to backport the patch on 6.4 branch since we just
> need to disable openGL.

I disagree, users might not know how to do it. let's backport it.
Comment 14 Commit Notification 2020-03-31 08:14:56 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/eb43950455a9b644bc06b17e2ce600be77d16343

tdf#131221: blacklist Intel on Win10 deviceid 0x5917

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Maxim Monastirsky 2020-03-31 11:33:52 UTC
(In reply to Commit Notification from comment #11)
> Julien Nabet committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> d4c9e2130f6f065b4a97fc98cf1029593e725e65
> 
> tdf#131221: blacklist Intel on Win10 deviceid 0x5917
> 
Did you check that this is indeed a problem with this specific driver, and not a global problem affecting the OpenGL code path (in which case blacklisting this specific driver makes no sense)? There are more reports of this in Bug 126388 - Do they all use the same driver?
Comment 16 Julien Nabet 2020-03-31 11:58:17 UTC
(In reply to Maxim Monastirsky from comment #15)
> ...
> Did you check that this is indeed a problem with this specific driver, and
> not a global problem affecting the OpenGL code path (in which case
> blacklisting this specific driver makes no sense)? There are more reports of
> this in Bug 126388 - Do they all use the same driver?

I didn't check this. I don't have any knowledge about OpenGL, I just know that there are lot of bugs related to it (because of LO or buggy drivers).
Feel free to revert the patch and investigate OpenGL if you want.