Download it now!
Bug 131225 - Fileopen DOCX: Page number Field Codes shown wrong (so "Seite 2" shown as "2 22")
Summary: Fileopen DOCX: Page number Field Codes shown wrong (so "Seite 2" shown as "2...
Status: RESOLVED DUPLICATE of bug 130241
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Header-Footer DOCX-Fields
  Show dependency treegraph
 
Reported: 2020-03-08 20:46 UTC by Ulrich Gemkow
Modified: 2020-03-18 14:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test document (17.98 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-03-08 20:46 UTC, Ulrich Gemkow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Gemkow 2020-03-08 20:46:26 UTC
Created attachment 158502 [details]
Test document

The attached .docx document has a page number field in its footer. With word, the first page has no page number, the following pages have the correct page number.

When opening this document with soffice

- a page number footer is shown on the first page

- the page number is displayed incorrect on both pages as "2 21" and "2 22"

----

Version: 6.4.1.2
Build ID: 1:6.4.1~rc2-0ubuntu0.18.04.1
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 BogdanB 2020-03-09 07:13:11 UTC
Yes, footer is ON in First Page Style. If you change to OFF it will not show your page number.

Version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 BogdanB 2020-03-09 07:16:02 UTC
I tested like this: I created a new document with a First Page style and Footer is OFF by default. So, it seems your First Page Style have been changed... So, LibreOffice is showing because it was changed to ON.
Comment 3 Ulrich Gemkow 2020-03-09 11:20:28 UTC
Thanks for looking into this. I am aware of the Page style settings.

But I would expect that an imported .docx document has the same look in soffice as it has in MS word (I know how difficult this is!)

In this sense this is IMHO a bug (or maybe two bugs) in the .docx filter.
Comment 4 Timur 2020-03-18 14:18:47 UTC
Field Code is something like this:
IF PAGENUM > 1  "Page  ""   \* MERGEFORMAT 1 

Looks like a duplicate of bug 130241.

*** This bug has been marked as a duplicate of bug 130241 ***