Download it now!
Bug 131249 - with embedded fonts, text orientation in table cell are not saved or not loaded to/from file
Summary: with embedded fonts, text orientation in table cell are not saved or not loa...
Status: RESOLVED DUPLICATE of bug 124470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables Fonts-Embedded
  Show dependency treegraph
 
Reported: 2020-03-09 23:30 UTC by animuspexus
Modified: 2020-03-17 13:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
1 - how should be (221.70 KB, image/png)
2020-03-09 23:31 UTC, animuspexus
Details
2 - how works (228.89 KB, image/png)
2020-03-09 23:32 UTC, animuspexus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description animuspexus 2020-03-09 23:30:46 UTC
Description:
In simple documents it works ok

But I have example document for you, in which change to text angle in table cell either doesn't save, either doesn't load to/from file (I don't know, maybe both)

I attaching two screenshots 
1. How I need text to be saved/loaded. this one taken right after save
2. How document looks after it's reload
and example document 'test.odt'

Steps to Reproduce:
1.select middle cell in example document
2.press right button and choose 'table properties'
3.go to 'text flow' tab 
4.select 'vertical (bottom to top)'
5.press ok
6.shrink middle cell to good looking size (I don't know if this step takes part in problem)
7.save document
8.close document
9.load document

Actual Results:
after reloading, text in middle cell looks as normal text and without normal angle

Expected Results:
angle of text in cell should be saved and loaded from file ok


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.3.4.2.0+
Build ID: 6.3.4.2-2.fc31
CPU threads: 2; OS: Linux 5.5; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 animuspexus 2020-03-09 23:31:39 UTC
Created attachment 158532 [details]
1 - how should be
Comment 2 animuspexus 2020-03-09 23:32:10 UTC
Created attachment 158533 [details]
2 - how works
Comment 3 animuspexus 2020-03-09 23:41:27 UTC
I had to place test.odt file into google drive, as it contains embedded fonts and is 42 MiB in size https://drive.google.com/open?id=1t1kDD15ZbbzaxsZJOe141zOHyhx25kUh
Comment 4 animuspexus 2020-03-09 23:44:16 UTC
I have to note, what, when I tried to remove embedded fonts, the cell 's text orientation saved/loaded normally. but with embedded fonts it's not working.
Comment 5 animuspexus 2020-03-09 23:49:47 UTC
> after reloading, text in middle cell looks as normal text and without normal
> without
*with
Comment 6 Durgapriyanka 2020-03-10 14:34:00 UTC
Thank you for reporting the bug.I can reproduce this bug in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 7 Dieter 2020-03-17 11:30:41 UTC
NEW because of comment 6
Comment 8 Timur 2020-03-17 13:44:44 UTC
This bug was wrongly marked from 3.3 and Linux, it's from 6.2. All.
Which makes it a duplicate. 

animuspexus, you made a clear report, except you should've searched if already reported. 

Durgapriyanka and Dieter, you are here too long to just just confirm behavior, at least without searching.

*** This bug has been marked as a duplicate of bug 124470 ***