Bug 131269 - A particular PPT with unusual order of Master-Note-Presentation fails to open in Impress
Summary: A particular PPT with unusual order of Master-Note-Presentation fails to ope...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: nd101
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: filter:ppt
: 79826 94590 98070 124337 127967 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-11 08:03 UTC by nd101
Modified: 2021-03-29 10:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
original MSO PPT document (4.04 MB, application/vnd.ms-powerpoint)
2020-03-11 08:08 UTC, nd101
Details
Impress (6.30 KB, image/png)
2020-03-11 08:13 UTC, nd101
Details
MSO (327.32 KB, image/png)
2020-03-11 08:13 UTC, nd101
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nd101 2020-03-11 08:03:01 UTC
Description:
We attached the PPT document that Impress fails to open. The PPT is a 1997-2003 MSO PPT document. In MSO, it opens normally and it has 27 slides. In Impress it shows only two empty slides. After our investigation into this problem, we think it maybe the problem of mixing up Master/Presentation/Note slides section in the import phase. The three sections are in the order of Master-Note-Presentation instead of the normal Master-Presentation-Note which MSO has no problem of opening it. We will submit a fix shortly for review. 

Steps to Reproduce:
1.open the attached ppt document
2.see the difference with MSO
3.

Actual Results:
2 wrong slides showing, 

Expected Results:
27 correct slides


Reproducible: Always


User Profile Reset: No



Additional Info:
27 correct slides
Comment 1 nd101 2020-03-11 08:08:47 UTC
Created attachment 158587 [details]
original MSO PPT document
Comment 2 nd101 2020-03-11 08:13:03 UTC
Created attachment 158588 [details]
Impress
Comment 3 nd101 2020-03-11 08:13:33 UTC
Created attachment 158589 [details]
MSO
Comment 5 Timur 2020-07-17 17:20:32 UTC
Xisco, please see this patch and add some reviewer.
Comment 6 Commit Notification 2020-11-26 16:55:24 UTC
nd101 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f1b5e0422b421de39c9fee9a87b6fceee8e48bbd

tdf#131269 - fix importing PPT with different notes/presentations order

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2021-01-04 16:51:52 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 2c9708cbb870483a8a1c93d722085be5f789d234
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@nd101, thanks for fixing this issue!!
Comment 8 Xisco Faulí 2021-03-29 07:51:44 UTC
*** Bug 94590 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2021-03-29 07:53:28 UTC
*** Bug 98070 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2021-03-29 07:54:42 UTC
*** Bug 79826 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2021-03-29 07:57:05 UTC
*** Bug 127967 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2021-03-29 07:58:23 UTC
*** Bug 124337 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2021-03-29 09:49:17 UTC
nd101 committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/c4cdc0372881bb3693c28c4889e8759417715677

tdf#131269 - fix importing PPT with different notes/presentations order

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-03-29 10:07:37 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fc4881aafd70326830cd4e2b51cd09b55ea03ced

tdf#131269: sd_import: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.