Bug 131274 - When opening a CSV file with Calc, the default template is ignored.
Summary: When opening a CSV file with Calc, the default template is ignored.
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: CSV-Import
  Show dependency treegraph
 
Reported: 2020-03-11 10:45 UTC by Kouichi Nakamura
Modified: 2020-08-25 09:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kouichi Nakamura 2020-03-11 10:45:17 UTC
Description:
When opening a CSV file with Calc, the font setting of the default template is ignored. There appears no way to configure default font for CSV tables.

Steps to Reproduce:
Import a CSV file with Calc


Actual Results:
The font of the opened CSV file is always "Liberation Sans" no matter what font is used in the default template for Calc

Expected Results:
The users should be able to choose their font for CSV tables as well. 


Reproducible: Always


User Profile Reset: No



Additional Info:
It is odd that the default template is reflected by a new spreadsheet but not by an imported CSV file.
Comment 1 Heiko Tietze 2020-05-18 09:39:18 UTC
Please explain what the default template is and what you expect. If you mean Styles and Formatting > Default, that's a per document setting. And File > Templates > Manage Templates there is no default.
Comment 2 Roman Kuznetsov 2020-08-12 19:24:17 UTC
I understood the problem.

Steps:

1. Change Default cell style => change font to Liberation Serif
2. Save file as Template (File-Templates-Save as Template) and select "Set as default template option" there
3. Try create a new Calc file => we have a Libreration Serif font in every cell
4. Try import any CSV file
5. We have a Liberation Sans font in any cell with imported CSV file instead Liberation Serif

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

My opinion - in this case imported data should have cell format from default Calc template even it was changed

I don't think it's a UX bug. Heiko?
Comment 3 Mike Kaganski 2020-08-12 19:39:37 UTC
This is not a bug.

A (default) template is like existing document that is opened and copied when you create a new document. It isn't used when you open any existing document, even if the format is simple, such as CSV.

The template can contain column widths and row heights; it may contain styles; conditional formatting; headers and footers... using the template for CSV would appear as if  all that info  was in the file.

Doing otherwise would create surprise in users when they open a CSV, see headers there, edit, save and see it reverted to old headers (not "no headers" as reasonable per format, but old headers from template).

It could *maybe* follow e.g. Options->LO->Fonts->Font Settings for HTML, Basic and SQL sources. Personally I would prefer a per-filter configuration, e.g. own configuration for CSV. But that's a different issue, requiring own report.