Download it now!
Bug 131279 - FILEOPEN: DOCX: btlr text is displayed as tb-rl
Summary: FILEOPEN: DOCX: btlr text is displayed as tb-rl
Status: RESOLVED DUPLICATE of bug 131258
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: Text-Direction-Unification
  Show dependency treegraph
 
Reported: 2020-03-11 11:29 UTC by Xisco Faulí
Modified: 2020-03-13 15:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.0 master (113.72 KB, image/png)
2020-03-11 11:29 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-03-11 11:29:23 UTC
Created attachment 158601 [details]
Comparison MSO 2010 and LibreOffice 7.0 master

Steps to reproduce:
1. Open attachment 156700 [details] from bug 128880

-> See text in the first column. See comparison image

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: dde0cf9eafed91c88d9999a294ea32fe0e8aa4bc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-03-11 11:31:37 UTC
The text was displayed correctly until it disappeared in https://cgit.freedesktop.org/libreoffice/core/commit/?id=435ab51ec8920033b7865f27f4afee8a852a0b31 ( bug 128880 )
Later on, bug 128880 was fixed in 
https://git.libreoffice.org/core/commit/74f0105a2c140d078932576b457a327f3d2490a6 and the problem is reproducible since then.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2020-03-13 15:31:06 UTC
Actually this got fixed by https://git.libreoffice.org/core/commit/34f91740cde8e77bd429f468ce0d797d8b0c2af4
Closing as duplicate of bug 131258

*** This bug has been marked as a duplicate of bug 131258 ***