Download it now!
Bug 131291 - EDITING: Chart: Not possible to change format in labels ( only 6.3 )
Summary: EDITING: Chart: Not possible to change format in labels ( only 6.3 )
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.3 target:6.3.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-03-11 16:55 UTC by Xisco Faulí
Modified: 2020-03-16 17:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-03-11 16:55:48 UTC
Steps to reproduce:
1. Open attachment 158371 [details] from bug 131115
2. Edit the chart
3. Double click on the labels
4. Change format to something different

-> Nothing happens

Reproduced in

Version: 6.3.6.0.0+
Build ID: 5e191ec6b99c10454837cadf350102f370aac42b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

but not in

Version: 6.4.3.0.0+
Build ID: 2478e861e221b2080309614ca7b29ca6c06af92f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Version: 7.0.0.0.alpha0+
Build ID: dde0cf9eafed91c88d9999a294ea32fe0e8aa4bc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-03-11 16:59:05 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=d979eb16b9144c7ed230d7b0a4d0c1474664d7d0 ( libreoffice-6-3 branch ). It seems the commit needs other commits to play well. My suggestion is to revert it in libreoffice-6-3 only...
Comment 2 Commit Notification 2020-03-12 18:38:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/02c9e05551d69980e0757b1b0a624692ea21a96b

tdf#131291: Add UItest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-03-16 09:36:44 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/285313d2703aadbcf4007523b94c832b99e7c12b

tdf#131291: Add UItest

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-03-16 09:39:15 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/2af4d304992d2a508e0d79cd855b93ca7559ebef

tdf#131291: Revert "tdf#129173 tdf#129175 Fix number format of data labels"

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2020-03-16 17:26:10 UTC
Just for the record, I do verify it's fixed in

Version: 6.3.6.0.0+
Build ID: 2af4d304992d2a508e0d79cd855b93ca7559ebef
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

however, https://gerrit.libreoffice.org/c/core/+/90391 still fails because of another issue.

1. Open attachment 158371 [details] from bug 131115
2. Edit the chart
3. Double click on the labels
4. Change format to Currency
5. Close Data Label Dialog
6. Open the dialog again
7. Format

-> Number is preselected instead of Currency.
This problem was fixed in mas and libreoffice-6-4 by https://cgit.freedesktop.org/libreoffice/core/commit/?id=c0cd2d4e0fa70d6eaf3cd3929bc0ad4786e9f4ed