Bug 131292 - Native OSX file open/save dialog do not work anymore
Summary: Native OSX file open/save dialog do not work anymore
Status: RESOLVED DUPLICATE of bug 128233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-11 16:56 UTC by Vincent Boudry
Modified: 2020-06-03 09:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Boudry 2020-03-11 16:56:02 UTC
Description:
Since the update to 6.4 the OS dialogs to load and save files do not open at all.
A spinning wheel stays for ~20sec, then disappear and that's it.
Using the native LibreOffice (Options>LibreOffice>General>Open/Save dialogs) still works.

Steps to Reproduce:
1.File>Open
2.Wait
3.Go to 1.

Actual Results:
Nothing.
Cannot open or save using dialogs.

Expected Results:
back to normal.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
-
Comment 1 Julien Nabet 2020-03-11 19:01:00 UTC
What MacOs do you use? It may be related to Catalina.

See tdf#126638
Comment 2 Vincent Boudry 2020-03-12 15:52:06 UTC
I am using MacOS 10.15.3 (19D76).
And yes, indeed that's related; sorry I missed it.
Comment 3 Vincent Boudry 2020-03-12 15:53:44 UTC

*** This bug has been marked as a duplicate of bug 126638 ***
Comment 4 Rob 2020-05-31 21:51:22 UTC
(In reply to Vincent Boudry from comment #2)
> I am using MacOS 10.15.3 (19D76).
> And yes, indeed that's related; sorry I missed it.

I fail to see the relation. This bug states that the save dialog doesn't even open; That's something else then unable to paste.
Comment 5 Rob 2020-05-31 21:58:20 UTC
(In reply to Vincent Boudry from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 126638 ***

Please reopen.

The built in dialogs are so clumsy compared with the system ones that I moved back to LO 6.3.6.2

Every time when there is an announcement of a new version, I install it, test it, and uptil now moved back to LO 6.3.6.2
Comment 6 Alex Thurgood 2020-06-02 08:48:49 UTC

*** This bug has been marked as a duplicate of bug 128233 ***
Comment 7 Vincent Boudry 2020-06-03 08:44:11 UTC
(In reply to Rob from comment #5)
> (In reply to Vincent Boudry from comment #3)
> > 
> > *** This bug has been marked as a duplicate of bug 126638 ***
> 
> Please reopen.
> 
> The built in dialogs are so clumsy compared with the system ones that I
> moved back to LO 6.3.6.2
> 
> Every time when there is an announcement of a new version, I install it,
> test it, and uptil now moved back to LO 6.3.6.2

I confirm that my problem is related to Catalina and the access control.
Granting access to the full disk solves the issue.
Comment 8 Alex Thurgood 2020-06-03 09:26:52 UTC
Unfortunately, it is just a workaround, the user shouldn't have to jump through hoops and totally override the security settings in order to be able to open/save documents.